summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-24 19:40:56 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-24 21:26:01 +0200
commitaf8e3c7f7dfa10118416c5579e79618d8bc42dcc (patch)
tree3e1ac6bebbd9a6fe505f162d1d3f80dd7ef4fbcd /games-arcade
parentgames-arcade/sdlroids: Drop old (diff)
downloadgentoo-af8e3c7f7dfa10118416c5579e79618d8bc42dcc.tar.gz
gentoo-af8e3c7f7dfa10118416c5579e79618d8bc42dcc.tar.bz2
gentoo-af8e3c7f7dfa10118416c5579e79618d8bc42dcc.zip
games-arcade/sdlsasteroids: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch4
-rw-r--r--games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch4
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild58
3 files changed, 62 insertions, 4 deletions
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
index 5ee05328e897..9863f0c051e9 100644
--- a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-gcc43.patch
@@ -1,5 +1,5 @@
---- src/sbitmap.h
-+++ src/sbitmap.h
+--- a/src/sbitmap.h
++++ b/src/sbitmap.h
@@ -36,7 +36,7 @@
void LoadImage(char* path);
void LoadSurface(SDL_Surface* surface);
diff --git a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
index 302c912efe18..581010b51388 100644
--- a/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
+++ b/games-arcade/sdlsasteroids/files/sdlsasteroids-3.0.1-ldflags.patch
@@ -1,5 +1,5 @@
---- src/Makefile.old 2010-09-22 08:44:57.000000000 +0200
-+++ src/Makefile 2010-09-22 08:45:43.000000000 +0200
+--- a/src/Makefile.old 2010-09-22 08:44:57.000000000 +0200
++++ b/src/Makefile 2010-09-22 08:45:43.000000000 +0200
@@ -26,7 +26,7 @@
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..24ecc1564280
--- /dev/null
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Rework of Sasteroids using SDL"
+HOMEPAGE="http://sdlsas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdlsas/SDLSasteroids-${PV}.tar.gz"
+
+LICENSE="GPL-2 freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ media-libs/sdl-mixer
+ media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/SDLSasteroids-${PV}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e 's/make /$(MAKE) /' \
+ -e 's/--strip//' \
+ Makefile || die
+ sed -i \
+ -e '/^CC/d' \
+ -e 's/g++/$(CXX)/' \
+ -e 's/CC/CXX/' \
+ -e 's/CFLAGS/CXXFLAGS/' \
+ src/Makefile || die
+}
+
+src_compile() {
+ emake \
+ GAMEDIR="/usr/share/${PN}" \
+ OPTS="${CXXFLAGS}"
+}
+
+src_install() {
+ dodir /usr/share/man/man6/
+ emake \
+ GAMEDIR="${D}/usr/share/${PN}" \
+ BINDIR="${D}/usr/bin" \
+ MANDIR="${D}/usr/share/man/" \
+ install
+ dodoc ChangeLog README README.xast TODO description
+ newicon graphics/sprite/bigast.png ${PN}.png
+ make_desktop_entry sasteroids "Sasteroids" ${PN}
+}