summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/ascal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/ascal')
-rw-r--r--games-board/ascal/Manifest1
-rw-r--r--games-board/ascal/ascal-0.1.1.ebuild32
-rw-r--r--games-board/ascal/files/ascal-0.1.1-gcc43.patch30
-rw-r--r--games-board/ascal/files/ascal-0.1.1-install.patch70
-rw-r--r--games-board/ascal/metadata.xml17
5 files changed, 150 insertions, 0 deletions
diff --git a/games-board/ascal/Manifest b/games-board/ascal/Manifest
new file mode 100644
index 000000000000..08997bcd3d77
--- /dev/null
+++ b/games-board/ascal/Manifest
@@ -0,0 +1 @@
+DIST ascal-0.1.1.tar.bz2 960688 SHA256 43a5e19d5b2e33ffcaa11b2b2d4dcd62f975f87617505fd3356190c694476ac9 SHA512 4428040396da85dd8598ece34909b1db80fe2f72c36b8e0d23c3f9db5837ee30ec2a10ee74def97a80bafbbf1927cbdb6c598aa5f0a42949d3c490672f8c5165 WHIRLPOOL 53ded3517eb1a07ea6e8a9a7bcd701cab4122806355ad0169df13286ae9aaa0729c4efa54ac0e009d3ca383ed5920c3a7e64517d3f17444a29103024194aa1e1
diff --git a/games-board/ascal/ascal-0.1.1.ebuild b/games-board/ascal/ascal-0.1.1.ebuild
new file mode 100644
index 000000000000..2f0bdbc6094d
--- /dev/null
+++ b/games-board/ascal/ascal-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="A game similar to Draughts but with some really cool enhancements"
+HOMEPAGE="http://ascal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ascal/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-cpp/libgnomecanvasmm
+ dev-cpp/libglademm
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-board/ascal/files/ascal-0.1.1-gcc43.patch b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
new file mode 100644
index 000000000000..4b3829ec46a5
--- /dev/null
+++ b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
@@ -0,0 +1,30 @@
+--- src/gui.cpp.old 2009-01-18 21:11:58.000000000 +0100
++++ src/gui.cpp 2009-01-18 21:12:33.000000000 +0100
+@@ -21,6 +21,7 @@
+ #include "shareddata.hpp"
+ #include "config.h"
+ #include <string>
++#include <libintl.h>
+
+ gui::gui(shareddata *newData): GuiBoard() {
+ //clean, cleaner - pointer ;)
+--- src/gui_board.cpp.old 2009-01-18 21:13:30.000000000 +0100
++++ src/gui_board.cpp 2009-01-18 21:13:50.000000000 +0100
+@@ -20,6 +20,7 @@
+ #include <math.h>
+ #include "helper.h"
+ #include <stack>
++#include <libintl.h>
+
+
+ gui_board::gui_board() {
+--- src/board.cpp.old 2009-01-18 21:14:27.000000000 +0100
++++ src/board.cpp 2009-01-18 21:14:58.000000000 +0100
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+ #include "board.hpp"
++#include <cstdlib>
+ //#define DEBUG
+ #include "ourmove.hpp"
+ #include "helper.h"
diff --git a/games-board/ascal/files/ascal-0.1.1-install.patch b/games-board/ascal/files/ascal-0.1.1-install.patch
new file mode 100644
index 000000000000..b4902998f65f
--- /dev/null
+++ b/games-board/ascal/files/ascal-0.1.1-install.patch
@@ -0,0 +1,70 @@
+--- configure.ac
++++ configure.ac
+@@ -63,9 +63,6 @@
+ AC_DEFINE(DEBUG, 1, [Enable debug msg.])
+ CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
+ CPPFLAGS="$CPPFLAGS -g -O0"
+-else
+- CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
+- CPPFLAGS="$CPPFLAGS -O3"
+ fi
+
+ AC_ARG_ENABLE(Werror,
+@@ -74,7 +71,7 @@
+ )
+
+ if test "$enable_Werror" = yes; then
+- CPPFLAGS="$CPPFLAGS -Werror -Wall"
++ CPPFLAGS="$CPPFLAGS -Wall"
+ fi
+
+ AC_ARG_ENABLE(static,
+--- m4/Makefile.am
++++ m4/Makefile.am
+@@ -15,6 +15,5 @@
+ m4macros =
+
+ # The following is boilerplate
+-m4data_DATA = $(m4macros)
+ EXTRA_DIST =
+
+--- Makefile.am
++++ Makefile.am
+@@ -17,13 +17,12 @@
+
+ ACLOCAL_AMFLAGS = -I m4
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = ascal.png
+
+-desktopdir = $(datadir)/applications
++desktopdir = /usr/share/applications
+ desktop_in_files = ascal.desktop.in
+-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+ @INTLTOOL_DESKTOP_RULE@
+
+-#include aminclude.am
+\ No newline at end of file
++#include aminclude.am
+--- po/Makefile.in.in
++++ po/Makefile.in.in
+@@ -34,7 +34,7 @@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++itlocaledir = /usr/share/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -50,5 +50,5 @@
+
+
+
+-INCLUDES = $(ASCAL_CFLAGS) $(GTKMM) -DLOCALEDIR=\""$(datadir)/locale"\" -DASCAL_DATA_PREFIX=\""$(ASCAL_DATA_PREFIX)"\"
++INCLUDES = $(ASCAL_CFLAGS) $(GTKMM) -DLOCALEDIR=\""/usr/share/locale"\" -DASCAL_DATA_PREFIX=\""$(ASCAL_DATA_PREFIX)"\"
+ LIBS = $(ASCAL_LIBS) $(GTKMM)
diff --git a/games-board/ascal/metadata.xml b/games-board/ascal/metadata.xml
new file mode 100644
index 000000000000..c91d82b15a7d
--- /dev/null
+++ b/games-board/ascal/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Lasca (or Laska) is a game similar to Draughts but with some really cool
+enhancements. You'll find a great description in the help system of Ascal. In
+the meantime the article on Wikipedia and on
+http://research.interface.co.uk/lasca/about.htm will help you understanding the
+rules. Ascal tries to give a great Gnome Version of Lasca for one and two
+players. You can undo moves, save and load games and all that on a nifty
+graphical board.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ascal</remote-id>
+ </upstream>
+</pkgmetadata>