summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-08 13:20:35 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-08 13:24:27 -0500
commit9168c3eb358259c3c3e80fedf1019607d179ada6 (patch)
tree7b624eaf7ec9abbcf739e6a282f48b825a6e94bf /games-board/ascal
parentgames-board/atakks: remove deprecated games eclass (diff)
downloadgentoo-9168c3eb358259c3c3e80fedf1019607d179ada6.tar.gz
gentoo-9168c3eb358259c3c3e80fedf1019607d179ada6.tar.bz2
gentoo-9168c3eb358259c3c3e80fedf1019607d179ada6.zip
games-board/ascal: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/ascal')
-rw-r--r--games-board/ascal/ascal-0.1.1-r1.ebuild38
-rw-r--r--games-board/ascal/files/ascal-0.1.1-gcc43.patch12
-rw-r--r--games-board/ascal/files/ascal-0.1.1-install.patch20
3 files changed, 54 insertions, 16 deletions
diff --git a/games-board/ascal/ascal-0.1.1-r1.ebuild b/games-board/ascal/ascal-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..f00b82c296da
--- /dev/null
+++ b/games-board/ascal/ascal-0.1.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A game similar to Draughts but with some really cool enhancements"
+HOMEPAGE="http://ascal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ascal/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-cpp/libglademm
+ dev-cpp/libgnomecanvasmm
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-install.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf
+}
diff --git a/games-board/ascal/files/ascal-0.1.1-gcc43.patch b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
index 4b3829ec46a5..b2a55584fb0b 100644
--- a/games-board/ascal/files/ascal-0.1.1-gcc43.patch
+++ b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
@@ -1,5 +1,5 @@
---- src/gui.cpp.old 2009-01-18 21:11:58.000000000 +0100
-+++ src/gui.cpp 2009-01-18 21:12:33.000000000 +0100
+--- a/src/gui.cpp 2009-01-18 21:11:58.000000000 +0100
++++ b/src/gui.cpp 2009-01-18 21:12:33.000000000 +0100
@@ -21,6 +21,7 @@
#include "shareddata.hpp"
#include "config.h"
@@ -8,8 +8,8 @@
gui::gui(shareddata *newData): GuiBoard() {
//clean, cleaner - pointer ;)
---- src/gui_board.cpp.old 2009-01-18 21:13:30.000000000 +0100
-+++ src/gui_board.cpp 2009-01-18 21:13:50.000000000 +0100
+--- a/src/gui_board.cpp 2009-01-18 21:13:30.000000000 +0100
++++ b/src/gui_board.cpp 2009-01-18 21:13:50.000000000 +0100
@@ -20,6 +20,7 @@
#include <math.h>
#include "helper.h"
@@ -18,8 +18,8 @@
gui_board::gui_board() {
---- src/board.cpp.old 2009-01-18 21:14:27.000000000 +0100
-+++ src/board.cpp 2009-01-18 21:14:58.000000000 +0100
+--- a/src/board.cpp 2009-01-18 21:14:27.000000000 +0100
++++ b/src/board.cpp 2009-01-18 21:14:58.000000000 +0100
@@ -15,6 +15,7 @@
// Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
diff --git a/games-board/ascal/files/ascal-0.1.1-install.patch b/games-board/ascal/files/ascal-0.1.1-install.patch
index b4902998f65f..51a82a535eb8 100644
--- a/games-board/ascal/files/ascal-0.1.1-install.patch
+++ b/games-board/ascal/files/ascal-0.1.1-install.patch
@@ -1,5 +1,5 @@
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -63,9 +63,6 @@
AC_DEFINE(DEBUG, 1, [Enable debug msg.])
CPPFLAGS=[`echo "$CXXFLAGS" | $SED -e 's/-O[0-9]*//g'`]
@@ -19,8 +19,8 @@
fi
AC_ARG_ENABLE(static,
---- m4/Makefile.am
-+++ m4/Makefile.am
+--- a/m4/Makefile.am
++++ b/m4/Makefile.am
@@ -15,6 +15,5 @@
m4macros =
@@ -28,8 +28,8 @@
-m4data_DATA = $(m4macros)
EXTRA_DIST =
---- Makefile.am
-+++ Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
@@ -17,13 +17,12 @@
ACLOCAL_AMFLAGS = -I m4
@@ -48,8 +48,8 @@
-#include aminclude.am
\ No newline at end of file
+#include aminclude.am
---- po/Makefile.in.in
-+++ po/Makefile.in.in
+--- a/po/Makefile.in.in
++++ b/po/Makefile.in.in
@@ -34,7 +34,7 @@
datarootdir = @datarootdir@
libdir = @libdir@
@@ -59,8 +59,8 @@
subdir = po
install_sh = @install_sh@
# Automake >= 1.8 provides @mkdir_p@.
---- src/Makefile.am
-+++ src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -50,5 +50,5 @@