summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-03 17:44:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-03 17:44:38 +0200
commitd1fd0846fa55f34ed1ed4825ec2a1a70fe159f04 (patch)
treec3c1d1d4f6762adac276739f57a1ce7e55644d47 /games-board/ccgo/files/ccgo-0.3.6.5-tinfo.patch
parentmedia-sound/spotify: add USE=libressl (diff)
downloadgentoo-d1fd0846fa55f34ed1ed4825ec2a1a70fe159f04.tar.gz
gentoo-d1fd0846fa55f34ed1ed4825ec2a1a70fe159f04.tar.bz2
gentoo-d1fd0846fa55f34ed1ed4825ec2a1a70fe159f04.zip
games-board/ccgo: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/687278 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-board/ccgo/files/ccgo-0.3.6.5-tinfo.patch')
-rw-r--r--games-board/ccgo/files/ccgo-0.3.6.5-tinfo.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-board/ccgo/files/ccgo-0.3.6.5-tinfo.patch b/games-board/ccgo/files/ccgo-0.3.6.5-tinfo.patch
new file mode 100644
index 000000000000..aaa8b5ae0f9c
--- /dev/null
+++ b/games-board/ccgo/files/ccgo-0.3.6.5-tinfo.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/687278
+
+--- ccgo-0.3.6.5/configure.ac
++++ ccgo-0.3.6.5/configure.ac
+@@ -30,7 +30,7 @@
+ PKG_CHECK_MODULES(GTKMM, gtkmm-2.4 gconfmm-2.6)
+ AC_SUBST(GTKMM_CFLAGS)
+ AC_SUBST(GTKMM_LIBS)
+-AC_CHECK_HEADERS(ncurses.h, [have_ncurses=true], [have_ncurses=false])
++PKG_CHECK_MODULES(NCURSES, ncurses, [have_ncurses=true], [have_ncurses=false])
+ AM_CONDITIONAL([HAVE_NCURSES], [test x$have_ncurses = xtrue])
+
+ AM_GNU_GETTEXT([external])
+--- ccgo-0.3.6.5/Makefile.am
++++ ccgo-0.3.6.5/Makefile.am
+@@ -53,7 +53,7 @@
+ nctest_SOURCES = \
+ nctest.cc \
+ nc.cc nc.hh
+-nctest_LDADD = arg.o debug.o ui/libui.a go/libgo.a -lncurses
++nctest_LDADD = arg.o debug.o ui/libui.a go/libgo.a $(NCURSES_LIBS)
+ endif
+
+ gtktest_SOURCES = gtktest.cc
+--- ccgo-0.3.6.5/nc/Makefile.am
++++ ccgo-0.3.6.5/nc/Makefile.am
+@@ -8,7 +8,7 @@
+ misc.cc misc.hh \
+ editor.cc editor.hh
+
+-LDADD = libnc.a -lncurses
++LDADD = libnc.a $(NCURSES_LIBS)
+ noinst_PROGRAMS =
+
+ noinst_PROGRAMS += test-entry