summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/domination
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/Manifest1
-rw-r--r--games-board/domination/domination-1.1.1.5.ebuild51
-rw-r--r--games-board/domination/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/games-board/domination/Manifest b/games-board/domination/Manifest
new file mode 100644
index 000000000000..3d3e3fdff812
--- /dev/null
+++ b/games-board/domination/Manifest
@@ -0,0 +1 @@
+DIST Domination_1.1.1.5.zip 6390032 SHA256 6e0dd1c869679cc80c7904d6512cf9f6fc858a985b60c5a33f3f3291d716f740 SHA512 116d96aded29f60e71eacc8069c6b9ad3b2e8b7e44ed06c730cdaf8e1de4b95650e928e1876feb6bcb08697cd6eaedf1529cf323855e2da652855d07e8337360 WHIRLPOOL cd3de0950075f6330931f0847bd048d9919afc6009bfe99b7f3f6bed09a1b7ade30ad918af23139db2b15baacfe79845d3ce75c42463c5aa59603d141639b251
diff --git a/games-board/domination/domination-1.1.1.5.ebuild b/games-board/domination/domination-1.1.1.5.ebuild
new file mode 100644
index 000000000000..864824d75145
--- /dev/null
+++ b/games-board/domination/domination-1.1.1.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+EANT_BUILD_TARGET="game"
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ newgamesbin "${S}"/FlashGUI.sh ${PN}
+ sed -i \
+ -e "s|cd.*|cd \"${GAMES_DATADIR}\"/${PN}|" \
+ "${D}${GAMES_BINDIR}"/${PN} \
+ || die
+ chmod +x "${D}${GAMES_BINDIR}"/${PN} || die
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r "${S}"/*
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+
+ prepgamesdirs
+}
diff --git a/games-board/domination/metadata.xml b/games-board/domination/metadata.xml
new file mode 100644
index 000000000000..3a3a4a6bd732
--- /dev/null
+++ b/games-board/domination/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">domination</remote-id>
+ </upstream>
+</pkgmetadata>