summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-18 00:08:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-18 00:08:28 +0200
commitdcbb79e33eaf7bc0ab2127d669052a213a871aee (patch)
treeb444a4e4fd8c8c2e54ea25d3b541edfb792eedc1 /games-board/natch
parentnet-mail/notmuch: Remove older stable versions (diff)
downloadgentoo-dcbb79e33eaf7bc0ab2127d669052a213a871aee.tar.gz
gentoo-dcbb79e33eaf7bc0ab2127d669052a213a871aee.tar.bz2
gentoo-dcbb79e33eaf7bc0ab2127d669052a213a871aee.zip
games-board/natch: Fixed build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/690078 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-board/natch')
-rw-r--r--games-board/natch/files/natch-2.4-tinfo.patch39
-rw-r--r--games-board/natch/natch-2.4-r1.ebuild20
2 files changed, 53 insertions, 6 deletions
diff --git a/games-board/natch/files/natch-2.4-tinfo.patch b/games-board/natch/files/natch-2.4-tinfo.patch
new file mode 100644
index 000000000000..92646aa54bba
--- /dev/null
+++ b/games-board/natch/files/natch-2.4-tinfo.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/690078
+
+--- Natch-2.4/configure.in
++++ Natch-2.4/configure.in
+@@ -25,17 +25,19 @@
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PATH_PROGS(GENGETOPT, gengetopt)
++PKG_PROG_PKG_CONFIG
+
+ dnl for txtc (Text-to-C compiler)
+ AC_PROG_AWK
+ LF_PROG_TXTC
+
+ dnl Checks for libraries.
+-AC_SEARCH_LIBS(
+- initscr,
+- ncurses curses,
++PKG_CHECK_MODULES(NCURSES, ncurses,[
+ AC_DEFINE(HAVE_LIBNCURSES,,
+- Define if you have curses library for visual mode. ), )
++ Define if you have curses library for visual mode. )
++ ],[
++ AC_MSG_ERROR([Cannot find ncurses lib])
++])
+
+ dnl Replace `main' with a function in -lpc:
+ dnl AC_CHECK_LIB(pc, main)
+--- Natch-2.4/src/Makefile.am
++++ Natch-2.4/src/Makefile.am
+@@ -29,7 +29,7 @@
+
+ Natch_SOURCES = main.c main.h types.h cmdline.c cmdline.h distance.c distance.h dis_type.h pcpj.c pcpj.h distimmo.c distimmo.h pcpj_deb.c pcpj_deb.h pcpjcapt.c pcpjcapt.h trajet.c trajet.h explorat.c explorat.h expltype.h pcpjcoup.c pcpjcoup.h hash.c hash.h pcpjtool.c pcpjtool.h myHashTable.c myHashTable.h langues.c langues.h screen.c screen.h common.h moves_order.c moves_order.h test_moves_order.c test_moves_order.h twin_squares.c twin_squares.h precise_trajectories.c precise_trajectories.h captInitSquare.c captInitSquare.h piece.c piece.h reportbugs.text copyright.text
+
+-Natch_LDADD = @LIBOBJS@
++Natch_LDADD = @LIBOBJS@ $(NCURSES_LIBS)
+
+ AM_CFLAGS = -Wall -fshort-enums -DNDEBUG -O3
+ #AM_CFLAGS = -Wall -fshort-enums
diff --git a/games-board/natch/natch-2.4-r1.ebuild b/games-board/natch/natch-2.4-r1.ebuild
index 8b263b424b33..0e81bbc485f3 100644
--- a/games-board/natch/natch-2.4-r1.ebuild
+++ b/games-board/natch/natch-2.4-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit autotools
MY_P="Natch-${PV}"
DESCRIPTION="A program to solve chess proof games"
@@ -14,15 +15,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sys-libs/ncurses:0"
-RDEPEND=${DEPEND}
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${P}-format.patch
+ "${FILESDIR}"/${P}-tinfo.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_install() {
newbin src/Natch natch
dodoc AUTHORS ChangeLog NEWS README THANKS example.txt