summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-06 21:16:52 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-06 21:17:48 +0200
commit531458626fbced1d1402790d7623df10c4de29a4 (patch)
tree3f7a441a9df43adcf7baa99cb45b01497b39254e /games-board/pysolfc
parentnet-misc/nextcloud-client: initial commit (diff)
downloadgentoo-531458626fbced1d1402790d7623df10c4de29a4.tar.gz
gentoo-531458626fbced1d1402790d7623df10c4de29a4.tar.bz2
gentoo-531458626fbced1d1402790d7623df10c4de29a4.zip
games-board/pysolfc: Simplify, remove python-single-r1 inherit
Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/pysolfc')
-rw-r--r--games-board/pysolfc/pysolfc-2.0-r5.ebuild31
1 files changed, 7 insertions, 24 deletions
diff --git a/games-board/pysolfc/pysolfc-2.0-r5.ebuild b/games-board/pysolfc/pysolfc-2.0-r5.ebuild
index 6b7b75260a67..9dc1ce7e2070 100644
--- a/games-board/pysolfc/pysolfc-2.0-r5.ebuild
+++ b/games-board/pysolfc/pysolfc-2.0-r5.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk"
DISTUTILS_SINGLE_IMPL="1"
-inherit eutils python-single-r1 distutils-r1
+inherit eutils distutils-r1
MY_PN=PySolFC
SOL_URI="mirror://sourceforge/${PN}"
@@ -31,23 +31,12 @@ RDEPEND="${RDEPEND}
dev-tcltk/tktable )
sound? ( dev-python/pygame[${PYTHON_USEDEP}] )"
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-PIL-imports.patch" #471514
- "${FILESDIR}/${PN}-gentoo.patch" #591904
- )
-
- distutils-r1_python_prepare_all
-}
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- distutils-r1_src_prepare
+PATCHES=(
+ "${FILESDIR}/${PN}-PIL-imports.patch" #471514
+ "${FILESDIR}/${PN}-gentoo.patch" #591904
+)
+python_prepare_all() {
sed -i \
-e "/pysol.desktop/d" \
-e "s:share/icons:share/pixmaps:" \
@@ -55,10 +44,8 @@ src_prepare() {
setup.py || die
mv docs/README{,.txt} || die
-}
-src_compile() {
- distutils-r1_src_compile
+ distutils-r1_python_prepare_all
}
python_install_all() {
@@ -76,7 +63,3 @@ python_install_all() {
distutils-r1_python_install_all
}
-
-src_install() {
- distutils-r1_src_install
-}