summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-12 10:11:49 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-12 10:12:12 +0100
commitefe212ccd4e79cd70c9d343912913038445d84ee (patch)
tree5315448dcf817322b0bdf80a36cc6408dfefc3d8 /games-board/sirius/files
parentsys-apps/mlocate: Removed old. (diff)
downloadgentoo-efe212ccd4e79cd70c9d343912913038445d84ee.tar.gz
gentoo-efe212ccd4e79cd70c9d343912913038445d84ee.tar.bz2
gentoo-efe212ccd4e79cd70c9d343912913038445d84ee.zip
games-board/sirius: Fix underlinking
Gentoo-bug: 592414 * Turn sed's into PATCHES * Fix configure.ac * Include a check for sqrt() in libm * Simplify ebuild Package-Manager: portage-2.3.3
Diffstat (limited to 'games-board/sirius/files')
-rw-r--r--games-board/sirius/files/sirius-0.8.0-fix-build-system.patch65
-rw-r--r--games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch14
-rw-r--r--games-board/sirius/files/sirius-0.8.0-format.patch4
3 files changed, 81 insertions, 2 deletions
diff --git a/games-board/sirius/files/sirius-0.8.0-fix-build-system.patch b/games-board/sirius/files/sirius-0.8.0-fix-build-system.patch
new file mode 100644
index 000000000000..e799616a492a
--- /dev/null
+++ b/games-board/sirius/files/sirius-0.8.0-fix-build-system.patch
@@ -0,0 +1,65 @@
+Fix configure.ac
+* Remove setting CFLAGS
+* Look for sqrt() in libm (bug 592414)
+
+--- a/configure.in
++++ b/configure.in
+@@ -1,26 +1,23 @@
+ AC_PREREQ(2.52)
+
+-AC_INIT(sirius, 0.8.0)
+-AC_CONFIG_SRCDIR(src/sirius.c)
+-AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
++AC_INIT([sirius], [0.8.0])
++AC_CONFIG_SRCDIR([src/sirius.c])
++AM_INIT_AUTOMAKE
+
+-AM_CONFIG_HEADER(config.h)
+-
+-AM_MAINTAINER_MODE
++AC_CONFIG_HEADERS([config.h])
+
+ AC_PROG_INTLTOOL
+
+-AC_ISC_POSIX
+ AC_PROG_CC
+-AC_STDC_HEADERS
+-AM_PROG_LIBTOOL
+-AC_PROG_LIBTOOL
++LT_INIT
+
+ pkg_modules="gtk+-2.0 >= 1.3.13 gconf-2.0 libgnomeui-2.0 libgnomecanvas-2.0 libgnomeui-2.0 gdk-pixbuf-2.0"
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+-AC_SUBST(PACKAGE_CFLAGS)
+-AC_SUBST(PACKAGE_LIBS)
+
++dnl Look for sqrt() in libm
++AC_SEARCH_LIBS([sqrt], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrt() function])
++])
+
+ GETTEXT_PACKAGE=sirius
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE")
+@@ -29,22 +26,6 @@
+ ALL_LINGUAS="sv fr de ru"
+ AM_GLIB_GNU_GETTEXT
+
+-CFLAGS="-g -O3"
+-
+-AC_SUBST(CFLAGS)
+-AC_SUBST(CPPFLAGS)
+-AC_SUBST(LDFLAGS)
+-
+-dnl Use -Wall if we have gcc.
+-changequote(,)dnl
+-if test "x$GCC" = "xyes"; then
+- case " $CFLAGS " in
+- *[\ \ ]-Wall[\ \ ]*) ;;
+- *) CFLAGS="$CFLAGS -Wall" ;;
+- esac
+-fi
+-changequote([,])dnl
+-
+ AC_OUTPUT([
+ Makefile
+ po/Makefile.in
diff --git a/games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch b/games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch
new file mode 100644
index 000000000000..dfa411d5152b
--- /dev/null
+++ b/games-board/sirius/files/sirius-0.8.0-fix-desktop-file.patch
@@ -0,0 +1,14 @@
+Fix QA violations in desktop file
+
+--- a/sirius.desktop.in
++++ b/sirius.desktop.in
+@@ -3,7 +3,7 @@
+ _Name=Sirius
+ _Comment=Sirius, a othello playing program
+ Exec=sirius
+-Icon=sirius.png
++Icon=sirius
+ Terminal=false
+ Type=Application
+-Categories=GNOME;Application;Game;
++Categories=GNOME;Game;
diff --git a/games-board/sirius/files/sirius-0.8.0-format.patch b/games-board/sirius/files/sirius-0.8.0-format.patch
index 8dff431bf792..4bed292434d3 100644
--- a/games-board/sirius/files/sirius-0.8.0-format.patch
+++ b/games-board/sirius/files/sirius-0.8.0-format.patch
@@ -1,5 +1,5 @@
---- a/src/sirius.c 2016-01-14 21:22:53.946900371 +0100
-+++ b/src/sirius.c 2016-01-14 21:24:08.240507669 +0100
+--- a/src/sirius.c
++++ b/src/sirius.c
@@ -180,7 +180,7 @@
paus = 1;