summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2018-12-20 19:50:57 +0900
committerPatrice Clement <monsieurp@gentoo.org>2019-02-08 00:03:36 +0100
commit46fd3b34a333fbe516d901f955687c9367e663c0 (patch)
treeff2849f6face36ccbc4c3b1d7c2c1ac205dcd358 /games-board/teg
parentdev-java/libmso: update HOMEPAGE, SRC_URI. (diff)
downloadgentoo-46fd3b34a333fbe516d901f955687c9367e663c0.tar.gz
gentoo-46fd3b34a333fbe516d901f955687c9367e663c0.tar.bz2
gentoo-46fd3b34a333fbe516d901f955687c9367e663c0.zip
games-board/teg: add support for teg configure options.
The client, debug, ggz, robot, and server USE flag options are added. The htmltidy package is obsolete, so the respective dependency is replaced with a tidy-html5 dependency. In addition, the metadata.xml file is updated with a long description of the project, descriptions for the new flags, and a switch to the Github upstream remote id. The project release is now pulled from the project Github page, where the project moved from Sourceforge. Closes: https://bugs.gentoo.org/671448 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10668 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'games-board/teg')
-rw-r--r--games-board/teg/metadata.xml14
-rw-r--r--games-board/teg/teg-0.11.2-r1.ebuild31
2 files changed, 44 insertions, 1 deletions
diff --git a/games-board/teg/metadata.xml b/games-board/teg/metadata.xml
index 41e6e7c75fce..db57e70627ea 100644
--- a/games-board/teg/metadata.xml
+++ b/games-board/teg/metadata.xml
@@ -1,11 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <longdescription lang="en">
+ Tenes Empanadas Graciela (TEG) is a clone of 'Plan Tactico y
+ Estrategico de la Guerra', which is a pseudo-clone of Risk, a
+ multiplayer turn-based strategy game.
+ </longdescription>
<maintainer type="project">
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="client">Compile the client</flag>
+ <flag name="debug">Turn on debugging</flag>
+ <flag name="ggz">Enable GGZ Gaming Zone support</flag>
+ <flag name="robot">Compile the robot</flag>
+ <flag name="server">Compile the server</flag>
+ </use>
<upstream>
- <remote-id type="sourceforge">teg</remote-id>
+ <remote-id type="github">wfx/teg</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-board/teg/teg-0.11.2-r1.ebuild b/games-board/teg/teg-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..63ae34a6c6df
--- /dev/null
+++ b/games-board/teg/teg-0.11.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Gnome Risk Clone"
+HOMEPAGE="https://github.com/wfx/teg"
+SRC_URI="https://github.com/wfx/teg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+client debug ggz nls robot server"
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libgnomeui
+ gnome-base/libgnome
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-text/tidy-html5
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ $(use_enable client) \
+ $(use_enable debug) \
+ $(use_enable ggz) \
+ $(use_enable robot) \
+ $(use_enable server)
+}