summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-04-11 17:46:32 +0200
committerPacho Ramos <pacho@gentoo.org>2019-04-11 17:48:21 +0200
commit437277baea869281de79cba4936a15ff0388bb86 (patch)
treec1124713e05123f12d372d23ad069f51e6b24a0c /games-board
parentdev-libs/libcdio-paranoia: Needs subslot with soname version bumps (diff)
downloadgentoo-437277baea869281de79cba4936a15ff0388bb86.tar.gz
gentoo-437277baea869281de79cba4936a15ff0388bb86.tar.bz2
gentoo-437277baea869281de79cba4936a15ff0388bb86.zip
games-board/grhino: Disable optional libgnome2 support
Closes: https://bugs.gentoo.org/608432 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/grhino/grhino-0.16.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/grhino/grhino-0.16.1-r2.ebuild b/games-board/grhino/grhino-0.16.1-r2.ebuild
new file mode 100644
index 000000000000..004aa040e4f2
--- /dev/null
+++ b/games-board/grhino/grhino-0.16.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
+HOMEPAGE="http://rhino.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+
+ sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --localedir=/usr/share/locale \
+ --enable-gtp \
+ --disable-gnome \
+ $(use_enable nls)
+}