summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-09-23 00:57:10 +0100
committerStefan Strogin <steils@gentoo.org>2020-09-23 16:57:55 +0300
commit93d7783052a3c3a14813b18ee28244b773305929 (patch)
tree7f6c4c14efc12c13189cdc761cfd13a01f5a1a53 /games-board
parentnet-irc/ii: Stabilize 1.8 arm, #744169 (diff)
downloadgentoo-93d7783052a3c3a14813b18ee28244b773305929.tar.gz
gentoo-93d7783052a3c3a14813b18ee28244b773305929.tar.bz2
gentoo-93d7783052a3c3a14813b18ee28244b773305929.zip
games-board/gtkboard: fix build with gcc 10
Closes: https://bugs.gentoo.org/708536 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17642 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gtkboard/files/gtkboard-0.11_pre0-gcc10.patch14
-rw-r--r--games-board/gtkboard/gtkboard-0.11_pre0-r2.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc10.patch b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc10.patch
new file mode 100644
index 000000000000..249a790f0ee7
--- /dev/null
+++ b/games-board/gtkboard/files/gtkboard-0.11_pre0-gcc10.patch
@@ -0,0 +1,14 @@
+--- a/src/engine.c 2020-09-22 23:14:49.105745203 -0000
++++ b/src/engine.c 2020-09-22 23:53:45.862582851 -0000
+@@ -47,9 +47,9 @@ byte * engine_search (Pos *);
+ static FILE *engine_fin, *engine_fout;
+
+ //! Eval fn for white (can be NULL, in which case game_eval will be used for both)
+-ResultType (*game_eval_white) (Pos *, Player, float *);
++extern ResultType (*game_eval_white) (Pos *, Player, float *);
+ //! Eval fn for black (can be NULL, in which case game_eval will be used for both)
+-ResultType (*game_eval_black) (Pos *, Player, float *);
++extern ResultType (*game_eval_black) (Pos *, Player, float *);
+
+ // FIXME: following 3 extern decls must be removed by refactoring (i.e, move all fns common to client and server to a new file)
+ extern void reset_game_params ();
diff --git a/games-board/gtkboard/gtkboard-0.11_pre0-r2.ebuild b/games-board/gtkboard/gtkboard-0.11_pre0-r2.ebuild
index 2886f2c69ada..a37e9a95e119 100644
--- a/games-board/gtkboard/gtkboard-0.11_pre0-r2.ebuild
+++ b/games-board/gtkboard/gtkboard-0.11_pre0-r2.ebuild
@@ -31,6 +31,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc41.patch
"${FILESDIR}"/${P}-gcc45.patch
"${FILESDIR}"/${P}-stack-smash.patch
+ "${FILESDIR}"/${P}-gcc10.patch
)
src_prepare() {