summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2019-11-23 10:51:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 16:56:43 +0200
commit173a72ab19ebfb5807cb9d712421fdc078f15182 (patch)
treed068b789832caa3e6d60d5d83dd0531de44e8233 /games-emulation
parentprofiles: use.desc: Add 'gles2-only' global USE flag (diff)
downloadgentoo-173a72ab19ebfb5807cb9d712421fdc078f15182.tar.gz
gentoo-173a72ab19ebfb5807cb9d712421fdc078f15182.tar.bz2
gentoo-173a72ab19ebfb5807cb9d712421fdc078f15182.zip
games-emulation/mupen64plus-core: rename USE=gles2 to USE=gles2-only
Closes: https://github.com/gentoo/gentoo/pull/15133 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64plus-core/metadata.xml1
-rw-r--r--games-emulation/mupen64plus-core/mupen64plus-core-2.5.9-r1.ebuild (renamed from games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild)8
2 files changed, 4 insertions, 5 deletions
diff --git a/games-emulation/mupen64plus-core/metadata.xml b/games-emulation/mupen64plus-core/metadata.xml
index 4e8fd61a24ba..d4cc98359e4b 100644
--- a/games-emulation/mupen64plus-core/metadata.xml
+++ b/games-emulation/mupen64plus-core/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="debugger">Build the debugger</flag>
- <flag name="gles2">Use GLES2 instead of OpenGL</flag>
<flag name="new-dynarec">Enable new experimental dynamic recompiler implementation (only for x86 and arm)</flag>
<flag name="opencv">Support video capture via <pkg>media-libs/opencv</pkg></flag>
<flag name="osd">Overlay emulator messages using on-screen-display</flag>
diff --git a/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild b/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9-r1.ebuild
index 5bf2f73d58f8..57dc6a6f2305 100644
--- a/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild
+++ b/games-emulation/mupen64plus-core/mupen64plus-core-2.5.9-r1.ebuild
@@ -13,12 +13,12 @@ SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.ta
LICENSE="GPL-2+"
SLOT="0/2-sdl2"
KEYWORDS="~amd64 ~x86"
-IUSE="debugger gles2 lirc new-dynarec opencv +osd cpu_flags_x86_sse"
+IUSE="debugger gles2-only lirc new-dynarec opencv +osd cpu_flags_x86_sse"
RDEPEND="media-libs/libpng:0=
media-libs/libsdl2:0=[joystick,opengl,video]
sys-libs/zlib:0=[minizip]
- gles2? ( media-libs/libsdl2:0[gles] )
+ gles2-only? ( media-libs/libsdl2:0[gles] )
lirc? ( app-misc/lirc:0 )
opencv? ( media-libs/opencv:= )
osd? (
@@ -30,7 +30,7 @@ RDEPEND="media-libs/libpng:0=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="gles2? ( !osd )"
+REQUIRED_USE="gles2-only? ( !osd )"
S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-2.5.9-fix-gcc10-fno-common.patch )
@@ -82,7 +82,7 @@ src_compile() {
OPENCV=$(usex opencv 1 0)
DEBUGGER=$(usex debugger 1 0)
NEW_DYNAREC=$(usex new-dynarec 1 0)
- USE_GLES=$(usex gles2 1 0)
+ USE_GLES=$(usex gles2-only 1 0)
)
use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )