summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-24 00:31:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 11:09:36 +0100
commit8757085ff45841a5801ef65faa258bb2866233d8 (patch)
treef1892d691daa00dac9e4a11b570f96b2e4218ae0 /games-emulation
parentprofiles: Unmask app-text/poppler-0.84.0 (diff)
downloadgentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.gz
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.tar.bz2
gentoo-8757085ff45841a5801ef65faa258bb2866233d8.zip
*/*: Switch polynomial-c maintained packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mgba/mgba-0.7.3.ebuild8
-rw-r--r--games-emulation/mgba/mgba-0.8_beta1.ebuild8
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild8
3 files changed, 12 insertions, 12 deletions
diff --git a/games-emulation/mgba/mgba-0.7.3.ebuild b/games-emulation/mgba/mgba-0.7.3.ebuild
index 013c485228bf..759399b0d4b9 100644
--- a/games-emulation/mgba/mgba-0.7.3.ebuild
+++ b/games-emulation/mgba/mgba-0.7.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
@@ -44,7 +44,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
@@ -79,11 +79,11 @@ src_configure() {
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
diff --git a/games-emulation/mgba/mgba-0.8_beta1.ebuild b/games-emulation/mgba/mgba-0.8_beta1.ebuild
index 014fe2c0a7ce..035f986d3021 100644
--- a/games-emulation/mgba/mgba-0.8_beta1.ebuild
+++ b/games-emulation/mgba/mgba-0.8_beta1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
@@ -82,11 +82,11 @@ src_configure() {
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index 014fe2c0a7ce..035f986d3021 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="Game Boy Advance emulator written in C"
HOMEPAGE="https://mgba.io"
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}"
src_prepare() {
xdg_environment_reset
- cmake-utils_src_prepare
+ cmake_src_prepare
# Get rid of any bundled stuff we don't want
for pkg in libpng lzma sqlite3 zlib ; do
@@ -82,11 +82,11 @@ src_configure() {
-DUSE_SQLITE3="$(usex sqlite)"
-DUSE_ZLIB=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
}
src_install() {