summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-03-14 03:09:34 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-03-14 03:10:03 -0400
commit07c0b096283679b22592c21f6905eea1e36dc1e2 (patch)
tree10fd27b1e90375cb70e20c16c2d90e4c73a3d84c /games-engines/scummvm-tools
parentapp-emulation/wine: Update gcc 5.3 test case. #577306. Thanks to Bob Wya (diff)
downloadgentoo-07c0b096283679b22592c21f6905eea1e36dc1e2.tar.gz
gentoo-07c0b096283679b22592c21f6905eea1e36dc1e2.tar.bz2
gentoo-07c0b096283679b22592c21f6905eea1e36dc1e2.zip
games-engines/scummvm-tools: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-engines/scummvm-tools')
-rw-r--r--games-engines/scummvm-tools/Manifest1
-rw-r--r--games-engines/scummvm-tools/files/scummvm-tools-1.8.0-binprefix.patch11
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-1.8.0.ebuild58
3 files changed, 70 insertions, 0 deletions
diff --git a/games-engines/scummvm-tools/Manifest b/games-engines/scummvm-tools/Manifest
index 17fa75b64174..248076b40228 100644
--- a/games-engines/scummvm-tools/Manifest
+++ b/games-engines/scummvm-tools/Manifest
@@ -1 +1,2 @@
DIST scummvm-tools-1.7.0.tar.bz2 956801 SHA256 b4005c3d68e4c5bda4fa9e31f3998fc5b45b7c9381890ed3d5f0b57f77a62589 SHA512 6a04307912327cb91fb4e1689b67ce621c3e28cbd5460c20974384907d21cb266e9d00b74a6991813366d2c34f966d79dc12e71750d083c82b89a2ec654b04b1 WHIRLPOOL 2034eb3817b5e11b0ba626f2b2b88a2e29a973e538f7a43cafffa0247792c4292821dfa20decd18842155938a65cb74af35b18dbf5d0da61b2d4c18e1b1dc2fc
+DIST scummvm-tools-1.8.0.tar.xz 864048 SHA256 2c14050cee3fb8e178cb9ff16a4412ab584001757b4824c75b24240eb2d98bdd SHA512 eed0aa0cceef59c42aabe94fe382a4494085c479d310cb624131746a1cbacc37d4a43603a5321167eb5fd4d9d8235fc794bdca5a3417fc4d224213e5409347ed WHIRLPOOL a16fd22cda96b1c633a5c0b70cbfc9393ece6ac4da8f52393e2041cafe2091fb1b57f006ec507f320f69a172c3e522faed521047379ba2c154541070173a348a
diff --git a/games-engines/scummvm-tools/files/scummvm-tools-1.8.0-binprefix.patch b/games-engines/scummvm-tools/files/scummvm-tools-1.8.0-binprefix.patch
new file mode 100644
index 000000000000..604db075395c
--- /dev/null
+++ b/games-engines/scummvm-tools/files/scummvm-tools-1.8.0-binprefix.patch
@@ -0,0 +1,11 @@
+--- scummvm-tools-1.7.0.orig/Makefile.common
++++ scummvm-tools-1.7.0/Makefile.common
+@@ -312,7 +312,7 @@
+ install: $(TARGETS)
+ $(INSTALL) -p -m 0755 -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -p -m 0755 -d $(DESTDIR)$(DATADIR)/scummvm-tools
+- for i in $^ ; do $(INSTALL) -p -m 0755 $$i $(DESTDIR)$(BINDIR) ; done
++ for i in $^ ; do $(INSTALL) -p -m 0755 $$i $(DESTDIR)$(BINDIR)/$(EXEPREFIX)$$i ; done
+ $(INSTALL) -m 0755 -d $(DESTDIR)$(DATADIR)/scummvm-tools
+ $(INSTALL) -p -m 0644 $(srcdir)/gui/media/*.* $(DESTDIR)$(DATADIR)/scummvm-tools
+
diff --git a/games-engines/scummvm-tools/scummvm-tools-1.8.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-1.8.0.ebuild
new file mode 100644
index 000000000000..53e6d1be0b75
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-1.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER=3.0
+inherit wxwidgets eutils flag-o-matic games
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="http://scummvm.org/frs/scummvm-tools/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="flac iconv mad png vorbis"
+RESTRICT="test" # some tests require external files
+
+RDEPEND="png? ( media-libs/libpng:0 )
+ mad? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ vorbis? ( media-libs/libvorbis )
+ iconv? ( virtual/libiconv media-libs/freetype:2 )
+ sys-libs/zlib
+ >=dev-libs/boost-1.32
+ x11-libs/wxGTK:${WX_GTK_VER}"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+src_prepare() {
+ need-wxwidgets unicode
+ rm -rf *.bat dists/win32
+ sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
+ epatch "${FILESDIR}/${P}-binprefix.patch"
+}
+
+src_configure() {
+ # Not an autoconf script
+ ./configure \
+ --enable-verbose-build \
+ --mandir=/usr/share/man \
+ --prefix="${GAMES_PREFIX}" \
+ --libdir="${GAMES_PREFIX}/lib" \
+ --datadir="${GAMES_DATADIR}" \
+ --disable-tremor \
+ $(use_enable flac) \
+ $(use_enable iconv) \
+ $(use_enable iconv freetype) \
+ $(use_enable mad) \
+ $(use_enable png) \
+ $(use_enable vorbis) || die
+}
+
+src_install() {
+ EXEPREFIX="${PN}-" default
+ prepgamesdirs
+}