summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-07-19 12:34:07 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-07-19 12:49:49 +0100
commit22595dccc4a9a3db38fdd6acc4055463cb375a7a (patch)
treef7dcdde571164f2ba4ef3f017f494f873e78109c /games-engines/scummvm-tools
parentgames-engines/scummvm-tools: Add missing libpng SLOT operator (diff)
downloadgentoo-22595dccc4a9a3db38fdd6acc4055463cb375a7a.tar.gz
gentoo-22595dccc4a9a3db38fdd6acc4055463cb375a7a.tar.bz2
gentoo-22595dccc4a9a3db38fdd6acc4055463cb375a7a.zip
games-engines/scummvm-tools: EAPI 7
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/scummvm-tools')
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-2.1.0.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/games-engines/scummvm-tools/scummvm-tools-2.1.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-2.1.0.ebuild
index b0f58bbfe2ad..54cbb5e6684d 100644
--- a/games-engines/scummvm-tools/scummvm-tools-2.1.0.ebuild
+++ b/games-engines/scummvm-tools/scummvm-tools-2.1.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
WX_GTK_VER=3.0-gtk3
inherit wxwidgets eutils flag-o-matic
@@ -15,17 +15,22 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="flac iconv mad png vorbis"
RESTRICT="test" # some tests require external files
-RDEPEND=">=dev-libs/boost-1.32:=
+RDEPEND="
+ >=dev-libs/boost-1.32:=
sys-libs/zlib
x11-libs/wxGTK:${WX_GTK_VER}
flac? ( media-libs/flac )
iconv? ( virtual/libiconv media-libs/freetype:2 )
mad? ( media-libs/libmad )
png? ( media-libs/libpng:0= )
- vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig"
+ vorbis? ( media-libs/libvorbis )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}/${PN}-1.8.0-binprefix.patch"
@@ -34,12 +39,13 @@ PATCHES=(
src_prepare() {
default
- need-wxwidgets unicode
rm -rf *.bat dists/win32 || die
sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
}
src_configure() {
+ setup-wxwidgets
+
# Not an autoconf script
./configure \
--prefix=/usr \