summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-07-19 12:48:25 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-07-19 12:49:52 +0100
commitb88d0de5681c2987e7f65cc5e5fa16b73187f02a (patch)
tree944602ba5efb6591c75eadfe4406210d56da7db9 /games-engines
parentgames-engines/scummvm-tools: EAPI 7 (diff)
downloadgentoo-b88d0de5681c2987e7f65cc5e5fa16b73187f02a.tar.gz
gentoo-b88d0de5681c2987e7f65cc5e5fa16b73187f02a.tar.bz2
gentoo-b88d0de5681c2987e7f65cc5e5fa16b73187f02a.zip
games-engines/scummvm: Allow dependency on GLES 1/2 instead of OpenGL
I'm slightly unsure about this but there seems little point in forcing one API at build time when it can switch at runtime. It's not clear whether GLES support is needed at build time to be able to use it at runtime. Closes: https://bugs.gentoo.org/731776 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/scummvm-2.1.2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/games-engines/scummvm/scummvm-2.1.2.ebuild b/games-engines/scummvm/scummvm-2.1.2.ebuild
index 2eb60298d28..5f7022f1055 100644
--- a/games-engines/scummvm/scummvm-2.1.2.ebuild
+++ b/games-engines/scummvm/scummvm-2.1.2.ebuild
@@ -25,7 +25,7 @@ RDEPEND="
mp3? ( media-libs/libmad )
mpeg2? ( media-libs/libmpeg2 )
net? ( media-libs/sdl2-net )
- opengl? ( virtual/opengl )
+ opengl? ( || ( virtual/opengl media-libs/mesa[gles2] media-libs/mesa[gles1] ) )
png? ( media-libs/libpng:0 )
speech? ( app-accessibility/speech-dispatcher )
truetype? ( media-libs/freetype:2 )