summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/duke3d-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/duke3d-data')
-rw-r--r--games-fps/duke3d-data/Manifest1
-rw-r--r--games-fps/duke3d-data/duke3d-data-1.0-r2.ebuild77
-rw-r--r--games-fps/duke3d-data/duke3d-data-1.0.ebuild42
-rw-r--r--games-fps/duke3d-data/metadata.xml8
4 files changed, 128 insertions, 0 deletions
diff --git a/games-fps/duke3d-data/Manifest b/games-fps/duke3d-data/Manifest
new file mode 100644
index 000000000000..87fedf379202
--- /dev/null
+++ b/games-fps/duke3d-data/Manifest
@@ -0,0 +1 @@
+DIST gog_duke_nukem_3d_1.0.0.7.tar.gz 30376296 SHA256 ba81c81d5f35f3aa424d30d9ab1c8441f8967bf4776cc85299efc95eea257ea3 SHA512 d0471bdc65b1030e080de382fea661d78348769d13bca2115ba1fb22aa2de54298bcaa4807c7315d0e2e4eefcc04bc9489d4e4c75fe0db1e99dd0ccd4e138450 WHIRLPOOL 4766138fd3decf78db00e7b6d6ad8128d742454573b56a880b94dba63b7de2438afc0e402e22eca0f0c6ca589f78ef6a28cfd0fbe5e62e40e3ce7427b2daa5fd
diff --git a/games-fps/duke3d-data/duke3d-data-1.0-r2.ebuild b/games-fps/duke3d-data/duke3d-data-1.0-r2.ebuild
new file mode 100644
index 000000000000..0933f550621e
--- /dev/null
+++ b/games-fps/duke3d-data/duke3d-data-1.0-r2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CDROM_OPTIONAL="yes"
+inherit eutils cdrom games
+
+GOG_FILE="gog_duke_nukem_3d_1.0.0.7.tar.gz"
+DESCRIPTION="Duke Nukem 3D data files"
+HOMEPAGE="http://www.3drealms.com/"
+SRC_URI="gog? ( ${GOG_FILE} )"
+
+LICENSE="DUKE3D gog? ( GOG-EULA )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="gog"
+REQUIRED_USE="^^ ( cdinstall gog )"
+RESTRICT="mirror bindist gog? ( fetch )"
+
+RDEPEND="|| ( games-fps/eduke32 games-fps/duke3d )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download ${GOG_FILE} from your GOG.com account after buying Duke Nukem 3d"
+ einfo "and put it into ${DISTDIR}."
+}
+
+src_unpack() {
+ if use cdinstall ; then
+ export CDROM_NAME_SET=(
+ "Existing Install"
+ "Duke Nukem 3D CD"
+ "Duke Nukem 3D Atomic Edition CD"
+ )
+ cdrom_get_cds duke3d.grp:dvd/dn3dinst/duke3d.grp:atominst/duke3d.grp
+
+ if [[ ${CDROM_SET} -ne 0
+ && ${CDROM_SET} -ne 1
+ && ${CDROM_SET} -ne 2 ]]
+ then
+ die "Error locating data files.";
+ fi
+ else
+ unpack "${GOG_FILE}"
+ cd "Duke Nukem 3D/data" || die
+
+ # convert to lowercase
+ find . -type f \
+ -execdir sh -c 'echo "converting ${1} to lowercase"
+ lower="`echo "${1}" | tr [:upper:] [:lower:]`"
+ [ "${1}" = "${lower}" ] || mv "${1}" "${lower}"' - {} \;
+ fi
+}
+
+src_install() {
+ local DATAROOT
+
+ insinto "${GAMES_DATADIR}"/duke3d
+
+ if use cdinstall ; then
+ case ${CDROM_SET} in
+ 0) DATAROOT="" ;;
+ 1) DATAROOT="dn3dinst/" ;;
+ 2) DATAROOT="atominst/" ;;
+ esac
+
+ # avoid double slash
+ doins "${CDROM_ROOT}"/${DATAROOT}{duke3d.grp,duke.rts,game.con,user.con,demo?.dmo,defs.con}
+ else
+ doins "Duke Nukem 3D/data"/{duke3d.grp,duke.rts,game.con,user.con,demo?.dmo,defs.con}
+ fi
+
+ prepgamesdirs
+}
diff --git a/games-fps/duke3d-data/duke3d-data-1.0.ebuild b/games-fps/duke3d-data/duke3d-data-1.0.ebuild
new file mode 100644
index 000000000000..2f9401140ea2
--- /dev/null
+++ b/games-fps/duke3d-data/duke3d-data-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils cdrom games
+
+DESCRIPTION="Duke Nukem 3D data files"
+HOMEPAGE="http://www.3drealms.com/"
+SRC_URI=""
+
+LICENSE="DUKE3D"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( games-fps/eduke32 games-fps/duke3d )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ export CDROM_NAME_SET=("Existing Install" "Duke Nukem 3D CD")
+ cdrom_get_cds duke3d.grp:dvd/dn3dinst/duke3d.grp
+
+ if [[ ${CDROM_SET} -ne 0 && ${CDROM_SET} -ne 1 ]] ; then
+ die "Error locating data files.";
+ fi
+}
+
+src_install() {
+ local DATAROOT
+
+ case ${CDROM_SET} in
+ 0) DATAROOT= ;;
+ 1) DATAROOT="dn3dinst/" ;;
+ esac
+
+ insinto "${GAMES_DATADIR}"/duke3d
+ doins "${CDROM_ROOT}"/$DATAROOT/{duke3d.grp,duke.rts,game.con,user.con,demo2.dmo,defs.con,demo1.dmo} \
+ || die "doins failed"
+ prepgamesdirs
+}
diff --git a/games-fps/duke3d-data/metadata.xml b/games-fps/duke3d-data/metadata.xml
new file mode 100644
index 000000000000..3fba2a006d70
--- /dev/null
+++ b/games-fps/duke3d-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='gog'>Extract the data from the GOG.com installer.</flag>
+ </use>
+</pkgmetadata>