summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/postal2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/postal2')
-rw-r--r--games-fps/postal2/Manifest2
-rw-r--r--games-fps/postal2/metadata.xml9
-rw-r--r--games-fps/postal2/postal2-1409.2-r2.ebuild69
3 files changed, 80 insertions, 0 deletions
diff --git a/games-fps/postal2/Manifest b/games-fps/postal2/Manifest
new file mode 100644
index 000000000000..4b533cc227a3
--- /dev/null
+++ b/games-fps/postal2/Manifest
@@ -0,0 +1,2 @@
+DIST postal2-1409.1.run 4816304 SHA256 7c34530f84acfcb120710660ae56264fdab28d74eb0dd0a351bef37f87e2b1b1 SHA512 5ff4880435394c552e7c1f33baf8dfdb71eb56fe5e3067eeb746826a25e585d3901292618668de50dc8bf641b2628a26a82cdf5b642e33f4113b55d72df9c4fe WHIRLPOOL 90ff13f14d93ed539596bd21170397b55bf688719ac58d33168f27b7bdc7d1b7f6a45835b050608efc4e5cf8483e2a5b5894ff750449fa66206ce36f037a993e
+DIST postal2-1409.2.run 5645624 SHA256 5b7456200d5777b350e2a1b01eefd8f74df9c5d880acd18eeab3af731d719fe7 SHA512 9fafcfec30d99e30b879318a96f484d3723853a213606f58b02a37631b4393ab4925022fcef3f84c95907269c6675090100358c16cec8b779140bf83fe7cb660 WHIRLPOOL 658936af2e3cbd7d90734749187c36b05e16cefbcb73dc12526c4ceb9d3a34197b362186d3d06436ffb63e2019329631a2e6de13fb8a8518bf4a43f06872e7c7
diff --git a/games-fps/postal2/metadata.xml b/games-fps/postal2/metadata.xml
new file mode 100644
index 000000000000..668ca6c70661
--- /dev/null
+++ b/games-fps/postal2/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>tristan@gentoo.org</email>
+ <name>Tristan Heaven</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-fps/postal2/postal2-1409.2-r2.ebuild b/games-fps/postal2/postal2-1409.2-r2.ebuild
new file mode 100644
index 000000000000..9d7af064f77a
--- /dev/null
+++ b/games-fps/postal2/postal2-1409.2-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker cdrom multilib games
+
+DESCRIPTION="Postal 2: Share the Pain"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=postal2"
+SRC_URI="http://updatefiles.linuxgamepublishing.com/${PN}/${P/%?/1}.run
+ http://updatefiles.linuxgamepublishing.com/${PN}/${P}.run"
+
+LICENSE="postal2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ amd64? ( sys-libs/glibc[multilib] sys-libs/libstdc++-v3:5[multilib] )
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,opengl,abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds .installation_data/linux-specific.tar.bz2
+ mkdir ${A}
+
+ local f
+ for f in * ; do
+ cd "${S}"/${f}
+ unpack_makeself ${f}
+ done
+}
+
+src_install() {
+ has_multilib_profile && ABI=x86
+
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ dodir "${dir}"
+ cd "${D}/${dir}"
+
+ ln -s "${CDROM_ROOT}"/.installation_data/*.bz2 .
+ unpack ./*.bz2
+ rm -f ./*.bz2
+
+ local d
+ for d in "${S}"/* ; do
+ pushd "${d}" > /dev/null
+ loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ popd > /dev/null
+ done
+
+ rm -f System/{libstdc++.so.5,libgcc_s.so.1}
+
+ dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so
+ dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0
+
+ games_make_wrapper ${PN} ./${PN}-bin "${dir}"/System .
+ doicon "${CDROM_ROOT}"/.installation_data/${PN}.xpm
+ make_desktop_entry ${PN} "Postal 2: Share the Pain"
+
+ prepgamesdirs
+}