summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/quake1-killer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/quake1-killer')
-rw-r--r--games-fps/quake1-killer/Manifest1
-rw-r--r--games-fps/quake1-killer/metadata.xml5
-rw-r--r--games-fps/quake1-killer/quake1-killer-2.2z.ebuild31
3 files changed, 37 insertions, 0 deletions
diff --git a/games-fps/quake1-killer/Manifest b/games-fps/quake1-killer/Manifest
new file mode 100644
index 000000000000..5970b9efa46c
--- /dev/null
+++ b/games-fps/quake1-killer/Manifest
@@ -0,0 +1 @@
+DIST kqp220z.zip 2952348 SHA256 be8a4f5471cbc68ace0c954012795a38b12ba21613418e111271049767ae1972 SHA512 8149795435cf72c4358dc35cce473482b718b67cc799ce4739d975cf5fe3e856735cbcd1f40c7b6a345aee8bf830147ecb37e312b1cb141b40c14cc95fd0f56e WHIRLPOOL 2d2b3356d73af0bcdba08f879f09538ea06772fcae3050342c6a57d5c007e8a371b1c7b373bc9aaf05d6a1a6ba6148497f12e4fd4bb361dcab7f05b28a1427d0
diff --git a/games-fps/quake1-killer/metadata.xml b/games-fps/quake1-killer/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/quake1-killer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/quake1-killer/quake1-killer-2.2z.ebuild b/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
new file mode 100644
index 000000000000..5122c1d66bf7
--- /dev/null
+++ b/games-fps/quake1-killer/quake1-killer-2.2z.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit games
+
+DESCRIPTION="The Killer Quake Patch"
+HOMEPAGE="http://kqp.horoy.com/"
+SRC_URI="http://www.gamers.org/pub/idgames2/quakec/compilations/kqp220z.zip
+ mirror://gentoo/kqp220z.zip"
+
+LICENSE="quake1-killer"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ echo ">>> Unpacking kqp220z.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/kqp220z.zip || die "unpacking kqp220z.zip failed"
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/quake1/killer"
+ doins -r *
+ prepgamesdirs
+}