summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/quake2-data
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/quake2-data')
-rw-r--r--games-fps/quake2-data/Manifest1
-rw-r--r--games-fps/quake2-data/metadata.xml5
-rw-r--r--games-fps/quake2-data/quake2-data-3.20.ebuild87
3 files changed, 93 insertions, 0 deletions
diff --git a/games-fps/quake2-data/Manifest b/games-fps/quake2-data/Manifest
new file mode 100644
index 000000000000..b4e5324ac0e9
--- /dev/null
+++ b/games-fps/quake2-data/Manifest
@@ -0,0 +1 @@
+DIST q2-3.20-x86-full-ctf.exe 19267584 SHA256 f82197c8c8089202a4b3a85d8833b0c2e827a709d205c760369407c212488baa
diff --git a/games-fps/quake2-data/metadata.xml b/games-fps/quake2-data/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/quake2-data/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/quake2-data/quake2-data-3.20.ebuild b/games-fps/quake2-data/quake2-data-3.20.ebuild
new file mode 100644
index 000000000000..4bac1cd90392
--- /dev/null
+++ b/games-fps/quake2-data/quake2-data-3.20.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit unpacker eutils cdrom games
+
+DESCRIPTION="iD Software's Quake 2 ... the data files"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="mirror://idsoftware/quake2/q2-${PV}-x86-full-ctf.exe"
+
+LICENSE="Q2EULA"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc sparc x86 ~x86-fbsd"
+IUSE="videos"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ games_pkg_setup
+ if has_version "games-fps/quake2-demodata[symlink]" ; then
+ eerror "The symlink for the demo data conflicts with the cdinstall data"
+ die "Unmerge games-fps/quake2-demodata to remove the conflict"
+ fi
+}
+
+src_unpack() {
+ export CDROM_NAME_SET=("Existing Install" "Ultimate Quake Edition" "Quake2 CD" "Quake4 Bonus DVD")
+ cdrom_get_cds baseq2:Install/patch:Install:Movies
+ # The .exe is just a self-extracting .zip
+ unpack_zip ${A}
+}
+
+src_install() {
+ dodoc DOCS/* 3.20_Changes.txt
+ newdoc ctf/readme.txt ctf-readme.txt
+ case ${CDROM_SET} in
+ 0) dohtml -r "${CDROM_ROOT}"/Install/DOCS/quake2_manual/* ;;
+ 1) dohtml -r "${CDROM_ROOT}"/Install/Docs/quake2_manual/* ;;
+ 2) dohtml -r "${CDROM_ROOT}"/Install/DOCS/quake2_manual/* ;;
+ 3) dodoc "${CDROM_ROOT}"/Docs/* ;;
+ esac
+
+ local baseq2_cdpath
+ case ${CDROM_SET} in
+ 0) baseq2_cdpath=${CDROM_ROOT}/baseq2;;
+ 1) baseq2_cdpath=${CDROM_ROOT}/Install/Data/baseq2;;
+ 2) baseq2_cdpath=${CDROM_ROOT}/Install/Data/baseq2;;
+ 3) baseq2_cdpath=${CDROM_ROOT}/setup/Data/baseq2;;
+ esac
+
+ dodir "${GAMES_DATADIR}"/quake2/baseq2
+
+ if use videos ; then
+ insinto "${GAMES_DATADIR}"/quake2/baseq2/video
+ doins "${baseq2_cdpath}"/video/* || die "doins videos"
+ fi
+
+ insinto "${GAMES_DATADIR}"/quake2/baseq2
+ doins "${baseq2_cdpath}"/pak0.pak || die "couldnt grab pak0.pak"
+ doins baseq2/*.pak || die "couldnt grab release paks"
+ doins baseq2/maps.lst || die "couldnt grab maps.lst"
+ dodir "${GAMES_DATADIR}"/quake2/baseq2/players
+ cp -R "${baseq2_cdpath}"/players/* baseq2/players/* \
+ "${D}/${GAMES_DATADIR}"/quake2/baseq2/players/ || die "couldnt grab player models"
+
+ for mod in ctf rogue xatrix ; do
+ if [[ -d ${baseq2_cdpath}/../${mod} ]] ; then
+ if use videos && [[ -d ${baseq2_cdpath}/../${mod}/video ]] ; then
+ insinto "${GAMES_DATADIR}"/quake2/${mod}/video
+ doins "${baseq2_cdpath}"/../${mod}/video/* 2>/dev/null
+ fi
+ if [[ -n $(ls "${baseq2_cdpath}"/../${mod}/*.pak 2>/dev/null) ]] ; then
+ insinto "${GAMES_DATADIR}"/quake2/${mod}
+ doins "${baseq2_cdpath}"/../${mod}/*.pak || die "doins ${mod} pak"
+ fi
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}"/quake2/ctf
+ doins ctf/*.{cfg,ico,pak} || die "couldnt grab ctf"
+
+ prepgamesdirs
+}