summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/ut2004-action
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/ut2004-action')
-rw-r--r--games-fps/ut2004-action/Manifest1
-rw-r--r--games-fps/ut2004-action/metadata.xml5
-rw-r--r--games-fps/ut2004-action/ut2004-action-1.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/games-fps/ut2004-action/Manifest b/games-fps/ut2004-action/Manifest
new file mode 100644
index 000000000000..a1ca1e1c4419
--- /dev/null
+++ b/games-fps/ut2004-action/Manifest
@@ -0,0 +1 @@
+DIST aut-r1-msuc.zip 323878282 RMD160 067a01cc92af9df8bed689cefeac70ca8d24e9f2 SHA1 da8709691a212cd500fd6192b6787345f3398015 SHA256 8ebd6746e3db888085a02cdee4524a2221d7dd6ba38c53bcf439db25c921f75f
diff --git a/games-fps/ut2004-action/metadata.xml b/games-fps/ut2004-action/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/ut2004-action/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-fps/ut2004-action/ut2004-action-1.ebuild b/games-fps/ut2004-action/ut2004-action-1.ebuild
new file mode 100644
index 000000000000..3eb00bc973e7
--- /dev/null
+++ b/games-fps/ut2004-action/ut2004-action-1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="Action movie mod"
+MOD_NAME="Action"
+MOD_DIR="action"
+MOD_ICON="aut.ico"
+
+inherit games games-mods
+
+HOMEPAGE="http://www.ateamproductions.net/"
+SRC_URI="aut-r1-msuc.zip"
+
+LICENSE="freedist"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please download ${SRC_URI} from:"
+ elog "http://www.atomicgamer.com/file.php?id=45011"
+ elog "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
+}