summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/fortune-mod-gentoo-dev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/fortune-mod-gentoo-dev')
-rw-r--r--games-misc/fortune-mod-gentoo-dev/Manifest2
-rw-r--r--games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20061115.ebuild26
-rw-r--r--games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20090306.ebuild28
-rw-r--r--games-misc/fortune-mod-gentoo-dev/metadata.xml12
4 files changed, 68 insertions, 0 deletions
diff --git a/games-misc/fortune-mod-gentoo-dev/Manifest b/games-misc/fortune-mod-gentoo-dev/Manifest
new file mode 100644
index 000000000000..1c6fdcca6cf3
--- /dev/null
+++ b/games-misc/fortune-mod-gentoo-dev/Manifest
@@ -0,0 +1,2 @@
+DIST fortune-gentoo-dev-20090306.tar.bz2 50355 SHA256 e44afa4c7e11ef854fe8e4b783eefe2caa9907c3d8e925f10de5f7cbbbb1acd5 SHA512 2a6014d1dc95cae8a50c8f502f8271a9b7bf349cb49076ac3e76f3da55f0e509caf27ee04827b1b42add1b42ae07824173495bb0dbed5421693508fff9f36acc WHIRLPOOL 1d24c583cb38549403857acbb2fe79093a177ed8d07fb171e756dff90046d12ba98db5deeb60b3cb152c2500142a9b3d157eb829d685b4c6800ed1542b70eee8
+DIST gentoo-dev-20061115.gz 39451 SHA256 b494fae306fa0c6b9783c9d8f0fc62ba35c207d3d4d1886795896d8729734d06
diff --git a/games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20061115.ebuild b/games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20061115.ebuild
new file mode 100644
index 000000000000..3ab384b586b7
--- /dev/null
+++ b/games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20061115.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Fortune database of #gentoo-dev quotes"
+HOMEPAGE="http://dev.gentoo.org/~avenj"
+SRC_URI="http://ircd.oppresses.us/~avenj/files/gentoo-dev-${PV}.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="games-misc/fortune-mod"
+
+S=${WORKDIR}
+
+src_compile() {
+ mv gentoo-dev-${PV} gentoo-dev || die
+ strfile gentoo-dev || die
+}
+
+src_install() {
+ insinto /usr/share/fortune
+ doins gentoo-dev gentoo-dev.dat || die
+}
diff --git a/games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20090306.ebuild b/games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20090306.ebuild
new file mode 100644
index 000000000000..f8df2e3c4567
--- /dev/null
+++ b/games-misc/fortune-mod-gentoo-dev/fortune-mod-gentoo-dev-20090306.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+DESCRIPTION="Fortune database of #gentoo-dev quotes"
+HOMEPAGE="http://www.gentoo.org/"
+MY_PN="fortune-gentoo-dev"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~robbat2/distfiles/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="offensive"
+
+RDEPEND="games-misc/fortune-mod"
+# Perl is used to build stuff only
+# and strfile belongs to fortune-mod
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ default
+ use offensive || rm -f "${D}"/usr/share/fortune/off/*
+}
diff --git a/games-misc/fortune-mod-gentoo-dev/metadata.xml b/games-misc/fortune-mod-gentoo-dev/metadata.xml
new file mode 100644
index 000000000000..066f9dbc7be2
--- /dev/null
+++ b/games-misc/fortune-mod-gentoo-dev/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ <description>Maintainer. Also, please submit snippets for the fortunes to
+ me.</description>
+</maintainer>
+</pkgmetadata>
+