summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-11 16:41:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-11 17:55:47 -0500
commit15c4c9bc738cb26b1f5c2e25cb0a0a16d53b5187 (patch)
tree27d6e12ecd6b7810e6f87547434dd8c3012962f9 /games-misc
parentgames-misc/nyancat: remove deprecated games eclass (diff)
downloadgentoo-15c4c9bc738cb26b1f5c2e25cb0a0a16d53b5187.tar.gz
gentoo-15c4c9bc738cb26b1f5c2e25cb0a0a16d53b5187.tar.bz2
gentoo-15c4c9bc738cb26b1f5c2e25cb0a0a16d53b5187.zip
games-misc/qlife: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/qlife/qlife-1.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-misc/qlife/qlife-1.1-r1.ebuild b/games-misc/qlife/qlife-1.1-r1.ebuild
new file mode 100644
index 000000000000..e56b0aedcad9
--- /dev/null
+++ b/games-misc/qlife/qlife-1.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils qmake-utils
+MY_PN=${PN/ql/QL}
+
+DESCRIPTION="Simulates the classical Game of Life invented by John Conway"
+HOMEPAGE="http://open-maker.tuxfamily.org/blog/index.php?post/2009/03/28/QLife"
+SRC_URI="http://open-maker.tuxfamily.org/blog/public/${PN}_linux.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}/sources
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ dobin ${MY_PN}
+ newicon data/egg.png ${PN}.png
+ make_desktop_entry ${MY_PN} ${MY_PN}
+}