summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-08-06 23:57:17 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-08 19:49:27 +0300
commit66b0e00b6ac74af4b9cf3673e741bef3d6f4140d (patch)
tree8b51766c82997bb643d60672fc88df1f23e148bf /games-misc
parentsci-chemistry/gelemental: version bump to 2.0.0 (diff)
downloadgentoo-66b0e00b6ac74af4b9cf3673e741bef3d6f4140d.tar.gz
gentoo-66b0e00b6ac74af4b9cf3673e741bef3d6f4140d.tar.bz2
gentoo-66b0e00b6ac74af4b9cf3673e741bef3d6f4140d.zip
games-misc/xcowsay: bump to version 1.4 & take maintainership
Changes to ebuild: - Updated homepage to https - Project now on Github - Corrected license - Bumped to EAPI=7 - Dropped not needed depedencies - Instead of deleting files after installation, disable compilation - Taking ownership by myself Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12628 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/xcowsay/Manifest1
-rw-r--r--games-misc/xcowsay/metadata.xml31
-rw-r--r--games-misc/xcowsay/xcowsay-1.4.ebuild55
3 files changed, 83 insertions, 4 deletions
diff --git a/games-misc/xcowsay/Manifest b/games-misc/xcowsay/Manifest
index ee181b6ab1ca..69ed9ca6032c 100644
--- a/games-misc/xcowsay/Manifest
+++ b/games-misc/xcowsay/Manifest
@@ -1 +1,2 @@
DIST xcowsay-1.3.tar.gz 269836 BLAKE2B 40eea935eb8784c182c03cf68c89f790c826f5162bbed526facee4d7488fb833e55bbecb9824d0b5e98abf3f5bc77068e150a1817f9745fb8ace11b7d7fdbb00 SHA512 b6f6493a988d8e8036ba9f2a0434627ffbd28eacd3330b256d8e6754b7be02eeb41390b28a8160091eca87d142e284adf2e2a37f22d715bca3b58ef1db8cdcf1
+DIST xcowsay-1.4.tar.gz 100014 BLAKE2B 59a82449bdefcfdb9f1fcf159e21374e36fb1e5af7db5bc61eb10166e5746bb0ce13f4321c904354f8e5b3bc8ae4625b0b12b339dd8013016e644c908f4b6ef0 SHA512 53370ba287ed2bf7d41cbf1bb8631e8da6933575956b38ee02f5aedae5bb49aede7e5e641fa7f93241f078a1a044920b387288ffbe2a10dd04fbe02932c67ca9
diff --git a/games-misc/xcowsay/metadata.xml b/games-misc/xcowsay/metadata.xml
index 6d3b8a616845..1ed004f61256 100644
--- a/games-misc/xcowsay/metadata.xml
+++ b/games-misc/xcowsay/metadata.xml
@@ -1,8 +1,31 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<use>
- <flag name="fortune">Installs the fortune-mod xcow binary</flag>
-</use>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ xcowsay displays a cute cow and message on your desktop.
+ Inspired by the original cowsay. It includes all these amazing features:
+ - Fully configurable!
+ - Calculates display time from amount of text
+ - Dream mode - display images in the bubble
+ - Can draw thought and speech bubbles
+ - Daemon mode! Send your cow messages over DBus!
+ - Three different sized cows provided
+ - fortune(6) wrapper program: xcowfortune - cow will deliver pearls of wisdom!
+ - Replace the naffness that is xmessage(1)
+ - Should work with any window manager
+ - Supports UTF-8 characters properly
+ - Automatic word wrapping
+ - Use alternative non-cow images if you like
+ </longdescription>
+ <use>
+ <flag name="fortune">Enable support for fortune cookies via <pkg>games-misc/fortune-mod</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/games-misc/xcowsay/xcowsay-1.4.ebuild b/games-misc/xcowsay/xcowsay-1.4.ebuild
new file mode 100644
index 000000000000..12288119e0cd
--- /dev/null
+++ b/games-misc/xcowsay/xcowsay-1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Displays a cute cow and message on your desktop"
+HOMEPAGE="
+ https://github.com/nickg/xcowsay
+ https://www.doof.me.uk/xcowsay/
+"
+SRC_URI="https://github.com/nickg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus fortune nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ virtual/awk
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+ dbus? ( dev-libs/dbus-glib )
+ fortune? ( games-misc/fortune-mod )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ if ! use fortune; then
+ sed -e 's/xcowfortune//g' -i src/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable dbus)
+ $(use_enable nls)
+ )
+
+ econf ${myeconfargs[@]}
+}