summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-04 21:30:42 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-04 21:30:42 -0400
commit88870669fd6c389e4f873715ec2aa8ee49ded6f2 (patch)
tree0b07655601bb204791f47a820f2d87062f4ec43c /games-misc
parentgames-util/nml: version bump (diff)
downloadgentoo-88870669fd6c389e4f873715ec2aa8ee49ded6f2.tar.gz
gentoo-88870669fd6c389e4f873715ec2aa8ee49ded6f2.tar.bz2
gentoo-88870669fd6c389e4f873715ec2aa8ee49ded6f2.zip
games-misc/opengfx: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/Manifest1
-rw-r--r--games-misc/opengfx/files/opengfx-0.5.4-Makefile.patch31
-rw-r--r--games-misc/opengfx/opengfx-0.5.4.ebuild38
3 files changed, 70 insertions, 0 deletions
diff --git a/games-misc/opengfx/Manifest b/games-misc/opengfx/Manifest
index e582bef8a8a2..a4fce1b6737e 100644
--- a/games-misc/opengfx/Manifest
+++ b/games-misc/opengfx/Manifest
@@ -1 +1,2 @@
DIST opengfx-0.5.3-source.tar.xz 9638892 SHA256 28d253ffa7a3618f7c4efb3b1076bc652204c2412d3cee57a6b9ffc13bda4014 SHA512 41b41192dcf95e2ac03e7028f55aca486c13a8709a62fe5970918494b0009ee07118e0d04d10426fea35ee82c842d28fc58f8c258df2e8ebe0b17e40c892f829 WHIRLPOOL 309c8e5ef1fb83328712c0516c55ecbc53f75117a1fc2aedbe9e61db05bf14ffe4f9fec6ff6a1f50dfc408735de3d5b754d97b026957b02271b213ffc32a9872
+DIST opengfx-0.5.4-source.tar.xz 9638204 SHA256 6b6e33dbe11b2c668c3b7ac1534b7a8eb567d702f42c99bd871c69e6682ee655 SHA512 42f8438c747b42a77cf9d86c5da60ce3ce84ed347d714c345f3871806f9e35f2ed4729b445e0ee319f3e2edd53458dfbaad5ca42e389c3a2e800bce19223cdb1 WHIRLPOOL 3cd952b9f0ddddcc61acc6077f828c40eccf87835964a9ecdf5b1e27e4e6569a13acce9224a0ba52b4ba2fca5906a3b990c24ac11bfbfeb6c3e5c1f859928184
diff --git a/games-misc/opengfx/files/opengfx-0.5.4-Makefile.patch b/games-misc/opengfx/files/opengfx-0.5.4-Makefile.patch
new file mode 100644
index 000000000000..169df96684ce
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-0.5.4-Makefile.patch
@@ -0,0 +1,31 @@
+--- opengfx-0.5.3-source/Makefile
++++ opengfx-0.5.3-source/Makefile
+@@ -99,8 +99,8 @@
+ AWK ?= awk
+ GREP ?= grep
+ PYTHON ?= python
+-UNIX2DOS ?= $(shell which unix2dos)
+-UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null && echo "-q" || echo "")
++UNIX2DOS ?= $(shell which unix2dos 2>/dev/null)
++UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null >&2 && echo "-q" || echo "")
+
+ # Graphics processing
+ GIMP ?= gimp
+@@ -196,7 +196,7 @@
+ endif
+
+ # Days of commit since 2000-1-1 00-00
+-REPO_DAYS_SINCE_2000 ?= $(shell $(PYTHON) -c "from datetime import date; print (date(`echo "$(REPO_DATE)" | sed s/-/,/g | sed s/,0/,/g`)-date(2000,1,1)).days")
++REPO_DAYS_SINCE_2000 ?= $(shell $(PYTHON) -c "from datetime import date; print ((date(`echo "$(REPO_DATE)" | sed s/-/,/g | sed s/,0/,/g`)-date(2000,1,1)).days)")
+
+ # Filename addition, if we're not building the default branch
+ REPO_BRANCH_STRING ?= $(shell if [ "$(REPO_BRANCH)" = "$(DEFAULT_BRANCH_NAME)" ]; then echo ""; else echo "-$(REPO_BRANCH)"; fi)
+@@ -719,7 +719,7 @@
+ $(_E)
+ endif
+ $(_E) "Release:"
+- $(_E) "bananas: Upload bundle to BaNaNaS
++ $(_E) "bananas: Upload bundle to BaNaNaS"
+ $(_E)
+ $(_E) "Valid command line variables are:"
+ $(_E) "Helper programmes:"
diff --git a/games-misc/opengfx/opengfx-0.5.4.ebuild b/games-misc/opengfx/opengfx-0.5.4.ebuild
new file mode 100644
index 000000000000..bc897b1e7487
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ GIMP= emake help # print out the env to make bug reports better
+ GIMP= _V= emake bundle_tar
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}