summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-07-26 12:35:27 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-26 12:41:13 +0300
commitc17c82f15182da50b5da05652c66b14bdc1953a8 (patch)
treef8a479f81f7f646229b243ed08e91891c8b933a0 /games-mud/gnome-mud/gnome-mud-9999.ebuild
parentgames-mud/gnome-mud: Fix license to GPL-2+ (was missing "or later") (diff)
downloadgentoo-c17c82f15182da50b5da05652c66b14bdc1953a8.tar.gz
gentoo-c17c82f15182da50b5da05652c66b14bdc1953a8.tar.bz2
gentoo-c17c82f15182da50b5da05652c66b14bdc1953a8.zip
games-mud/gnome-mud: add live version
Doesn't need gnet anymore, but aliases/triggers are unconfigurable still Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-mud/gnome-mud/gnome-mud-9999.ebuild')
-rw-r--r--games-mud/gnome-mud/gnome-mud-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-mud/gnome-mud/gnome-mud-9999.ebuild b/games-mud/gnome-mud/gnome-mud-9999.ebuild
new file mode 100644
index 000000000000..658791122a5f
--- /dev/null
+++ b/games-mud/gnome-mud/gnome-mud-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2 git-r3
+
+DESCRIPTION="GNOME MUD client"
+HOMEPAGE="https://wiki.gnome.org/Apps/GnomeMud"
+SRC_URI=""
+EGIT_REPO_URI="git://git.gnome.org/gnome-mud"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug gstreamer"
+
+RDEPEND="virtual/libintl
+ >=dev-libs/glib-2.36:2
+ >=gnome-base/libglade-2.0.1:2.0
+ >=x11-libs/gtk+-2.20.0:2
+ >=x11-libs/vte-0.11:0
+ dev-libs/libpcre
+ gnome-base/gconf:2
+ gstreamer? ( media-libs/gstreamer:1.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/rarian
+ >=dev-util/intltool-0.23
+ >=sys-devel/gettext-0.11.5"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gstreamer) \
+ $(use_enable debug debug-logger)
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS README ROADMAP" \
+ gnome2_src_install
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+}