summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 14:01:03 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commit0ff49b3af06d03bd8ce68400a0d4fa24e95e1761 (patch)
treedab2cf6106cf3f07a93a7a5cc97e26624ca00c03 /games-mud/kildclient
parentgames-mud/gnome-mud: remove deprecated games eclass (diff)
downloadgentoo-0ff49b3af06d03bd8ce68400a0d4fa24e95e1761.tar.gz
gentoo-0ff49b3af06d03bd8ce68400a0d4fa24e95e1761.tar.bz2
gentoo-0ff49b3af06d03bd8ce68400a0d4fa24e95e1761.zip
games-mud/kildclient: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud/kildclient')
-rw-r--r--games-mud/kildclient/kildclient-3.0.1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-mud/kildclient/kildclient-3.0.1-r1.ebuild b/games-mud/kildclient/kildclient-3.0.1-r1.ebuild
new file mode 100644
index 00000000000..02ae58e9209
--- /dev/null
+++ b/games-mud/kildclient/kildclient-3.0.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="Powerful MUD client with a built-in PERL interpreter"
+HOMEPAGE="http://kildclient.sourceforge.net"
+SRC_URI="mirror://sourceforge/kildclient/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnutls spell"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Locale-gettext
+ dev-perl/JSON
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ virtual/libintl
+ spell? ( app-text/gtkspell:3 )
+ gnutls? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localedir=/usr/share/locale \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use_with spell gtkspell) \
+ $(use_with gnutls libgnutls) \
+ $(use_with doc docs)
+}