summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 14:14:22 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commitacd59c1e0ee962bc3a80ecd01e6ec0b7f0f79230 (patch)
treed0205af34a0ad119526a87b40ff97bc28c7d59a5 /games-mud/powwow
parentgames-mud/mudix: remove deprecated games eclass (diff)
downloadgentoo-acd59c1e0ee962bc3a80ecd01e6ec0b7f0f79230.tar.gz
gentoo-acd59c1e0ee962bc3a80ecd01e6ec0b7f0f79230.tar.bz2
gentoo-acd59c1e0ee962bc3a80ecd01e6ec0b7f0f79230.zip
games-mud/powwow: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud/powwow')
-rw-r--r--games-mud/powwow/powwow-1.2.16-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-mud/powwow/powwow-1.2.16-r1.ebuild b/games-mud/powwow/powwow-1.2.16-r1.ebuild
new file mode 100644
index 000000000000..86654bce6755
--- /dev/null
+++ b/games-mud/powwow/powwow-1.2.16-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="PowWow Console MUD Client"
+HOMEPAGE="http://hoopajoo.net/projects/powwow.html"
+SRC_URI="http://hoopajoo.net/static/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+)
+
+src_prepare() {
+ default
+
+ # note that that the extra, seemingly-redundant files installed are
+ # actually used by in-game help commands
+ sed -i \
+ -e "s/pkgdata_DATA = powwow.doc/pkgdata_DATA = /" \
+ Makefile.am || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --includedir=/usr/include
+}
+
+src_install () {
+ DOCS="ChangeLog Config.demo Hacking NEWS powwow.doc powwow.help README.* TODO" \
+ default
+}