summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-07-19 19:24:03 +0300
committerMart Raudsepp <leio@gentoo.org>2017-07-19 19:24:25 +0300
commitb745232aa6d172768731cd9e0839730c5c17760c (patch)
tree17a62b9ddfb2127f472b12774187a40003af04f1 /games-mud
parentdev-db/mysql: Version bump for 5.6.37 (diff)
downloadgentoo-b745232aa6d172768731cd9e0839730c5c17760c.tar.gz
gentoo-b745232aa6d172768731cd9e0839730c5c17760c.tar.bz2
gentoo-b745232aa6d172768731cd9e0839730c5c17760c.zip
games-mud/gnome-mud: Use gstreamer 1.x and fix telnet option renegotiation
Gentoo-bug: 616000 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/gnome-mud/files/0.11.2-gst1.patch42
-rw-r--r--games-mud/gnome-mud/files/0.11.2-telopts-reenable.patch35
-rw-r--r--games-mud/gnome-mud/gnome-mud-0.11.2-r2.ebuild60
3 files changed, 137 insertions, 0 deletions
diff --git a/games-mud/gnome-mud/files/0.11.2-gst1.patch b/games-mud/gnome-mud/files/0.11.2-gst1.patch
new file mode 100644
index 000000000000..64c6682c6726
--- /dev/null
+++ b/games-mud/gnome-mud/files/0.11.2-gst1.patch
@@ -0,0 +1,42 @@
+From 15c37855ab3559efaeffcef651c98ed971ae84bb Mon Sep 17 00:00:00 2001
+From: Steven Jackson
+Date: Wed, 19 Apr 2017 20:02:57 +0100
+Subject: [PATCH] gstreamer: Upgrade to 1.0 from 0.10
+---
+ configure.ac | 6 +++---
+ gnome-mud.spec.in | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 50c4c81..125b054 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -76,7 +76,7 @@ LIBGNET_REQUIRED=0.22
+ VTE_REQUIRED=0.11.00
+ PCRE_REQUIRED=6.0.0
+ GCONF_REQUIRED=0.20
+-GSTREAMER_REQUIRED=0.10
++GSTREAMER_REQUIRED=1.0
+
+ PKG_CHECK_MODULES(GMUD, gtk+-2.0 >= $GTK_REQUIRED vte >= $VTE_REQUIRED libglade-2.0 >= $LIBGLADE_REQUIRED libpcre >= $PCRE_REQUIRED gmodule-2.0 >= $GMODULE_REQUIRED gnet-2.0 >= $LIBGNET_REQUIRED gconf-2.0 >= $GCONF_REQUIRED)
+ AC_SUBST(GMUD_CFLAGS)
+@@ -114,14 +114,14 @@ AC_ARG_ENABLE(gstreamer,
+ [Enable GStreamer used for MSP (Mud Sound Protocol) Default=auto]),,
+ enable_gstreamer=auto)
+ if test "x$enable_gstreamer" != "xno"; then
+- PKG_CHECK_EXISTS(gstreamer-0.10, have_gst=yes, have_gst=no)
++ PKG_CHECK_EXISTS(gstreamer-1.0, have_gst=yes, have_gst=no)
+ if test "x$have_gst" = "xno" -a "x$enable_gstreamer" = "xyes"; then
+ AC_MSG_ERROR([Gstreamer support explicitly requested but libgstreamer was not found])
+ fi
+ if test "x$have_gst" = "xyes"; then
+ AC_DEFINE(ENABLE_GST, 1, [Define if GStreamer should be enabled])
+ enable_gstreamer=yes
+- PKG_CHECK_MODULES(MSP, gstreamer-0.10 >= $GSTREAMER_REQUIRED)
++ PKG_CHECK_MODULES(MSP, gstreamer-1.0 >= $GSTREAMER_REQUIRED)
+ fi
+ fi
+ AM_CONDITIONAL(USE_GSTREAMER, test "x$enable_gstreamer" = xyes)
+--
+2.10.2
+
diff --git a/games-mud/gnome-mud/files/0.11.2-telopts-reenable.patch b/games-mud/gnome-mud/files/0.11.2-telopts-reenable.patch
new file mode 100644
index 000000000000..ebafe30c4cf4
--- /dev/null
+++ b/games-mud/gnome-mud/files/0.11.2-telopts-reenable.patch
@@ -0,0 +1,35 @@
+From 62b043beedc14741a000e848a004ba44982b28b8 Mon Sep 17 00:00:00 2001
+From: Steven Jackson
+Date: Wed, 19 Apr 2017 10:38:18 +0000
+Subject: [PATCH] mud-telnet: Fix re-enabling disabled TELOPTS
+
+When the server disabled a TELOPT it wasn't possible for it to
+re-enable it, as it should.
+
+Enabling and disabling MSP and CHARSET in the preferences window
+doesn't control the MudTelnetHandler enabled field, so this change
+doesn't break that. Those preferences are used at a higher level,
+in mud-window-view.c.
+
+Thanks to shentino for reporting and assisting with the fix.
+
+Bug report: https://bugzilla.gnome.org/show_bug.cgi?id=781452
+---
+ src/mud-telnet.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/mud-telnet.c b/src/mud-telnet.c
+index 052ba04..0fe274a 100644
+--- a/src/mud-telnet.c
++++ b/src/mud-telnet.c
+@@ -939,7 +939,7 @@ mud_telnet_handle_positive_nego(MudTelnet *telnet,
+ // his state to YES and send DO; otherwise send DONT
+ // FIXME-US/HIM
+ // FIXME: What to do in the opposite "him" gint value case?
+- if (mud_telnet_isenabled(telnet, opt_no, him))
++ if (mud_telnet_get_index_by_option(telnet, opt_no) != -1)
+ {
+ mud_telnet_set_telopt_state(opt, TELOPT_STATE_YES, bitshift);
+ mud_telnet_send_iac(telnet, affirmative, opt_no);
+--
+1.9.1
diff --git a/games-mud/gnome-mud/gnome-mud-0.11.2-r2.ebuild b/games-mud/gnome-mud/gnome-mud-0.11.2-r2.ebuild
new file mode 100644
index 000000000000..e5a061831eb8
--- /dev/null
+++ b/games-mud/gnome-mud/gnome-mud-0.11.2-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME MUD client"
+HOMEPAGE="https://wiki.gnome.org/Apps/GnomeMud"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="gstreamer"
+
+RDEPEND="virtual/libintl
+ dev-libs/libpcre
+ dev-perl/XML-Parser
+ gnome-base/gconf:2
+ >=gnome-base/libglade-2.0.1:2.0
+ gstreamer? ( media-libs/gstreamer:1.0 )
+ net-libs/gnet:2
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.11:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/rarian
+ >=dev-util/intltool-0.23
+ >=sys-devel/gettext-0.11.5"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-telopts-reenable.patch #616000
+ "${FILESDIR}"/${PV}-gst1.patch # Needs eautoreconf
+)
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable gstreamer)
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS PLUGIN.API README ROADMAP" \
+ gnome2_src_install
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ echo
+ elog "For proper plugin operation, please create ~/.gnome-mud/plugins/"
+ elog "if that directory doesn't already exist."
+ elog "The command to do that is:"
+ elog " mkdir -p ~/.gnome-mud/plugins/"
+ echo
+}