summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/enigma
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/enigma')
-rw-r--r--games-puzzle/enigma/Manifest1
-rw-r--r--games-puzzle/enigma/enigma-1.21-r1.ebuild74
-rw-r--r--games-puzzle/enigma/enigma-1.21.ebuild75
-rw-r--r--games-puzzle/enigma/files/enigma-1.21-build.patch110
-rw-r--r--games-puzzle/enigma/metadata.xml8
5 files changed, 268 insertions, 0 deletions
diff --git a/games-puzzle/enigma/Manifest b/games-puzzle/enigma/Manifest
new file mode 100644
index 000000000000..328b133424d7
--- /dev/null
+++ b/games-puzzle/enigma/Manifest
@@ -0,0 +1 @@
+DIST enigma-1.21.tar.gz 56409951 SHA256 d872cf067d8eb560d3bb1cb17245814bc56ac3953ae1f12e2229c8eb6f82ce01 SHA512 0cca56a193f0f416e0fde02caf2e30b61eef506b6c62e151ff575f5c130f1e2e778d77149007b114ebaeec3a3e793434328555cb5190954a0ae13ed6cee229f0 WHIRLPOOL 9583eaacd75c7a3cf5af172d1209771b599e6f8b0fed2b7ea6b0a76ccc2743615d47ac3199f56dd1e39203afc09a43d9aa5d8d879e38502b47d4b77274217b87
diff --git a/games-puzzle/enigma/enigma-1.21-r1.ebuild b/games-puzzle/enigma/enigma-1.21-r1.ebuild
new file mode 100644
index 000000000000..3148edc53fff
--- /dev/null
+++ b/games-puzzle/enigma/enigma-1.21-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="puzzle game similar to Oxyd"
+HOMEPAGE="http://www.nongnu.org/enigma/"
+SRC_URI="mirror://sourceforge/enigma-game/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+COMMON_DEPS="media-libs/sdl-ttf
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libpng:0=
+ sys-libs/zlib
+ net-misc/curl
+ || ( >=dev-libs/xerces-c-3[icu] >=dev-libs/xerces-c-3[-icu,-iconv] )
+ net-libs/enet
+ nls? ( virtual/libintl )"
+DEPEND="${COMMON_DEPS}
+ sys-devel/gettext"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/dejavu
+ x11-misc/xdg-utils"
+
+src_prepare() {
+ cp /usr/share/gettext/config.rpath .
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i \
+ -e "s:DOCDIR:\"/usr/share/doc/${P}/html\":" \
+ src/main.cc || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-system-enet \
+ $(use_enable nls)
+}
+
+src_install() {
+ DOCS="ACKNOWLEDGEMENTS AUTHORS CHANGES README doc/HACKING" \
+ default
+ dosym \
+ /usr/share/fonts/dejavu/DejaVuSansCondensed.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/DejaVuSansCondensed.ttf
+ dosym \
+ /usr/share/fonts/dejavu/DejaVuSans.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/vera_sans.ttf
+ dohtml -r doc/*
+ doman doc/enigma.6
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/enigma/enigma-1.21.ebuild b/games-puzzle/enigma/enigma-1.21.ebuild
new file mode 100644
index 000000000000..06ace23017a8
--- /dev/null
+++ b/games-puzzle/enigma/enigma-1.21.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="puzzle game similar to Oxyd"
+HOMEPAGE="http://www.nongnu.org/enigma/"
+SRC_URI="mirror://sourceforge/enigma-game/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+COMMON_DEPS="media-libs/sdl-ttf
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libpng:0=
+ sys-libs/zlib
+ net-misc/curl
+ || ( >=dev-libs/xerces-c-3[icu] >=dev-libs/xerces-c-3[-icu,-iconv] )
+ net-libs/enet
+ nls? ( virtual/libintl )"
+DEPEND="${COMMON_DEPS}
+ sys-devel/gettext"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/dejavu
+ media-fonts/ttf-bitstream-vera
+ x11-misc/xdg-utils"
+
+src_prepare() {
+ cp /usr/share/gettext/config.rpath .
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed -i \
+ -e "s:DOCDIR:\"/usr/share/doc/${P}/html\":" \
+ src/main.cc || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-system-enet \
+ $(use_enable nls)
+}
+
+src_install() {
+ DOCS="ACKNOWLEDGEMENTS AUTHORS CHANGES README doc/HACKING" \
+ default
+ dosym \
+ /usr/share/fonts/dejavu/DejaVuSansCondensed.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/DejaVuSansCondensed.ttf
+ dosym \
+ /usr/share/fonts/ttf-bitstream-vera/Vera.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/vera_sans.ttf
+ dohtml -r doc/*
+ doman doc/enigma.6
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-puzzle/enigma/files/enigma-1.21-build.patch b/games-puzzle/enigma/files/enigma-1.21-build.patch
new file mode 100644
index 000000000000..6d5e91ca76e4
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.21-build.patch
@@ -0,0 +1,110 @@
+diff -ru enigma-1.21.orig/Makefile.am enigma-1.21/Makefile.am
+--- enigma-1.21.orig/Makefile.am 2014-12-19 16:26:06.000000000 -0500
++++ enigma-1.21/Makefile.am 2015-02-06 18:20:22.239518323 -0500
+@@ -3,12 +3,9 @@
+ # tools -> lib-src/lua
+ # src -> tools, lib-src
+ #
+-SUBDIRS = m4 lib-src tools intl src data doc po etc
++SUBDIRS = m4 lib-src tools intl src data po etc
+ EXTRA_DIST = enigma CHANGES ACKNOWLEDGEMENTS
+
+-docdir = @datadir@/doc/enigma
+-doc_DATA = README CHANGES COPYING ACKNOWLEDGEMENTS
+-
+ ACLOCAL_AMFLAGS = -I m4
+
+ .PHONY: tolua
+diff -ru enigma-1.21.orig/configure.ac enigma-1.21/configure.ac
+--- enigma-1.21.orig/configure.ac 2014-12-19 16:26:06.000000000 -0500
++++ enigma-1.21/configure.ac 2015-02-06 18:20:22.282516643 -0500
+@@ -342,7 +342,6 @@
+ CXXFLAGS="$CXXFLAGS -O2 -ffast-math -fomit-frame-pointer"
+ AC_MSG_RESULT(yes)
+ else
+- CXXFLAGS="$CXXFLAGS -g"
+ AC_MSG_RESULT(no)
+ fi
+
+diff -ru enigma-1.21.orig/etc/Makefile.am enigma-1.21/etc/Makefile.am
+--- enigma-1.21.orig/etc/Makefile.am 2014-12-19 16:26:05.000000000 -0500
++++ enigma-1.21/etc/Makefile.am 2015-02-06 18:25:44.131945494 -0500
+@@ -1,18 +1,18 @@
+ # if !MINGW32
+ # Comply with xdg icon theme specification
+-icondir = $(prefix)/share/icons/hicolor/48x48/apps
++icondir = /usr/share/icons/hicolor/48x48/apps
+ icon_DATA = enigma.png
+
+ # Backwards-compatible global search location for images
+-pixmapdir = $(prefix)/share/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = enigma.png
+
+ # Install .desktop file in xdg standard location
+-desktopdir = $(prefix)/share/applications
++desktopdir = /usr/share/applications
+ desktop_DATA = enigma.desktop
+
+ # Install AppData file
+-appdatadir = $(prefix)/share/appdata
++appdatadir = /usr/share/appdata
+ dist_appdata_DATA = enigma.appdata.xml
+ # endif !MINGW32
+
+diff -ru enigma-1.21.orig/etc/enigma.desktop enigma-1.21/etc/enigma.desktop
+--- enigma-1.21.orig/etc/enigma.desktop 2014-12-19 16:26:05.000000000 -0500
++++ enigma-1.21/etc/enigma.desktop 2015-02-06 18:20:22.282516643 -0500
+@@ -1,5 +1,5 @@
+ [Desktop Entry]
+-Version=1.21
++Version=1.0
+ Name=Enigma
+ Name[be]=Enigma
+ Name[cs]=Enigma
+@@ -44,5 +44,5 @@
+ StartupNotify=false
+ Icon=enigma
+ Type=Application
+-Categories=Application;Game;PuzzleGame;
++Categories=Game;X-PuzzleGame;
+
+diff -ru enigma-1.21.orig/po/Makefile.in.in enigma-1.21/po/Makefile.in.in
+--- enigma-1.21.orig/po/Makefile.in.in 2014-12-19 16:26:06.000000000 -0500
++++ enigma-1.21/po/Makefile.in.in 2015-02-06 18:20:22.283516604 -0500
+@@ -25,12 +25,12 @@
+ exec_prefix = @exec_prefix@
+ datarootdir = @datarootdir@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = $(top_srcdir)/mkinstalldirs
+ #install_sh@ -d
+ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+diff -ru enigma-1.21.orig/src/Makefile.am enigma-1.21/src/Makefile.am
+--- enigma-1.21.orig/src/Makefile.am 2014-12-19 16:24:38.000000000 -0500
++++ enigma-1.21/src/Makefile.am 2015-02-06 18:20:22.283516604 -0500
+@@ -12,7 +12,7 @@
+ CXXFLAGS = @CXXFLAGS@\
+ -DSYSTEM_DATA_DIR=\"$(datadir)/enigma\" \
+ -DDOCDIR=\"$(docdir)\" \
+- -DLOCALEDIR=\"$(localedir_enigma)\" \
++ -DLOCALEDIR=\"/usr/share/locale\" \
+ -I$(top_srcdir)/lib-src/zipios++ \
+ -I$(top_builddir)/lib-src/zipios++ \
+ -I$(top_srcdir)/lib-src/lua \
+@@ -440,7 +440,7 @@
+
+ else # not MINGW32
+
+- localedir_enigma := $(datadir)/locale
++ localedir_enigma := /usr/share/locale
+ mingw_ldadd =
+
+ endif
diff --git a/games-puzzle/enigma/metadata.xml b/games-puzzle/enigma/metadata.xml
new file mode 100644
index 000000000000..88fbd37387dd
--- /dev/null
+++ b/games-puzzle/enigma/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">enigma-game</remote-id>
+ </upstream>
+</pkgmetadata>