summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/ensemblist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/ensemblist')
-rw-r--r--games-puzzle/ensemblist/Manifest1
-rw-r--r--games-puzzle/ensemblist/ensemblist-040126.ebuild40
-rw-r--r--games-puzzle/ensemblist/files/ensemblist-040126-build.patch41
-rw-r--r--games-puzzle/ensemblist/metadata.xml5
4 files changed, 87 insertions, 0 deletions
diff --git a/games-puzzle/ensemblist/Manifest b/games-puzzle/ensemblist/Manifest
new file mode 100644
index 000000000000..0ee7df4f98ee
--- /dev/null
+++ b/games-puzzle/ensemblist/Manifest
@@ -0,0 +1 @@
+DIST ensemblist-040126.tar.gz 1312095 SHA256 6cfd48b3f62a0853a08609a85841bea400a9fe0eb9d3b8bdf0f62dd5a8aa36be
diff --git a/games-puzzle/ensemblist/ensemblist-040126.ebuild b/games-puzzle/ensemblist/ensemblist-040126.ebuild
new file mode 100644
index 000000000000..f54f3356f58f
--- /dev/null
+++ b/games-puzzle/ensemblist/ensemblist-040126.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Put together several primitives to build a given shape. (C.S.G. Game)"
+HOMEPAGE="http://www.nongnu.org/ensemblist/index_en.html"
+SRC_URI="http://savannah.nongnu.org/download/ensemblist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND="media-libs/freeglut
+ media-libs/libmikmod:0
+ media-libs/libpng:0
+ virtual/glu
+ virtual/opengl
+ x11-libs/libXmu"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake DATADIR="\"${GAMES_DATADIR}\"/${PN}/datas" \
+ CFLAGSLD="${LDFLAGS}"
+}
+
+src_install() {
+ dogamesbin ensemblist
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r datas
+ dodoc Changelog README
+ make_desktop_entry ${PN} Ensemblist
+ prepgamesdirs
+}
diff --git a/games-puzzle/ensemblist/files/ensemblist-040126-build.patch b/games-puzzle/ensemblist/files/ensemblist-040126-build.patch
new file mode 100644
index 000000000000..42cc04070eef
--- /dev/null
+++ b/games-puzzle/ensemblist/files/ensemblist-040126-build.patch
@@ -0,0 +1,41 @@
+diff -ru ensemblist-040126.orig/Makefile ensemblist-040126/Makefile
+--- ensemblist-040126.orig/Makefile 2004-01-26 10:37:05.000000000 -0500
++++ ensemblist-040126/Makefile 2009-01-23 03:24:05.000000000 -0500
+@@ -1,17 +1,8 @@
+ NAME=ensemblist
+-CC=gcc
+-ifdef DEBUG
+-DATADIR=/home/rixed/src/ensemblist/datas
+-COMPILE_FLAGS=-Wall -fno-builtin -Wpointer-arith -Wcast-qual -Wcast-align -Wwrite-strings -Wredundant-decls -O0 -g `libmikmod-config --cflags` -DDATADIR=$(DATADIR)
+-LINK_FLAGS=-g -lm -L /usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lefence -lpthread
+-else
+ DATADIR=$(DESTDIR)/usr/share/$(NAME)
+-COMPILE_FLAGS=-Wall -O3 -fomit-frame-pointer `libmikmod-config --cflags` -DNDEBUG -DDATADIR=$(DATADIR)
+-LINK_FLAGS=-lm -L /usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lpthread
+-endif
++COMPILE_FLAGS=`libmikmod-config --cflags` -DDATADIR=$(DATADIR)
++LINK_FLAGS=-L/usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lpthread -lm
+ APPLE_FRAMEWORKS=-framework GLUT -framework Cocoa -framework OpenGL
+-#uncomment the following if you want to compile on MacOS/X
+-#LINK_FLAGS=$(LINK_FLAGS) $(APPLE_FRAMEWORKS)
+ CFILES=$(wildcard *.c)
+ OFILES=$(patsubst %.c,%.o,$(CFILES))
+
+@@ -22,15 +13,10 @@
+ all: $(NAME)
+
+ $(NAME): $(OFILES)
+- @echo '$(COL)$@$(NORM)'
+- $(CC) $(COMPILE_FLAGS) $(LINK_FLAGS) $^ -o $@
+-ifndef DEBUG
+- strip $(NAME)
+-endif
++ $(CC) $(CFLAGSLD) $(COMPILE_FLAGS) $^ -o $@ $(LINK_FLAGS)
+
+ .c.o:
+- @echo '$(COL)$@$(NORM)'
+- $(CC) $(COMPILE_FLAGS) -c $<
++ $(CC) $(CFLAGS) $(COMPILE_FLAGS) -c $<
+
+ clean:
+ @echo '$(COL)$@$(NORM)'
diff --git a/games-puzzle/ensemblist/metadata.xml b/games-puzzle/ensemblist/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/ensemblist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>