summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/gnome-sudoku
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/gnome-sudoku')
-rw-r--r--games-puzzle/gnome-sudoku/Manifest2
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-3.14.2.ebuild47
-rw-r--r--games-puzzle/gnome-sudoku/gnome-sudoku-3.16.0.ebuild48
-rw-r--r--games-puzzle/gnome-sudoku/metadata.xml5
4 files changed, 102 insertions, 0 deletions
diff --git a/games-puzzle/gnome-sudoku/Manifest b/games-puzzle/gnome-sudoku/Manifest
new file mode 100644
index 000000000000..68a5a1f1830f
--- /dev/null
+++ b/games-puzzle/gnome-sudoku/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-sudoku-3.14.2.tar.xz 3071084 SHA256 4364662b624d76e174f1930811061de5358c917e4f546c8e5ca234e120689301 SHA512 031e200d90d85c4ac1ffcda78e26cfa79f81cca442ea4d73b46e6f56e639e0885590b2156bb0c1781051712e4f095df69a352224f9acecc514eb8471211e4304 WHIRLPOOL c492e97fbd8318bcd2b92371e17d1eb868a3571b1db830e33bd398a62c5f1bab07704caae959b503baf6e30baa50dd5ee285623a5a71e307d2d516d1b5a21e35
+DIST gnome-sudoku-3.16.0.tar.xz 3063340 SHA256 bbeb4c410ac690df967fe494da92a40ded473ed28b2565c5e2f34af91be53dad SHA512 26567f0eeaa03dedaa22a86ed74404d70fb6954087222d3c5f0dc1f1aa3ad89307aec9c136c829dc4b0c39d028214c146d7c0c4b0080043f2f89405534da6914 WHIRLPOOL 8373e59f9763381888d162d62584e3ddaa45697261d29951849b99331cac712d155ff5671d73bec593b9e0736fb19132280bf13153b75d022f58af6747adf88f
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-3.14.2.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-3.14.2.ebuild
new file mode 100644
index 000000000000..4c666923324f
--- /dev/null
+++ b/games-puzzle/gnome-sudoku/gnome-sudoku-3.14.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.26"
+
+inherit gnome-games vala
+
+DESCRIPTION="Test your logic skills in this number grid puzzle"
+HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgee:0.8[introspection]
+ dev-libs/json-glib
+ >=dev-libs/qqwing-1.2
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.14.3:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/appdata-tools
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome-games_src_prepare
+}
+
+src_configure() {
+ # Workaround until we know how to fix bug #475318
+ gnome-games_src_configure \
+ --prefix="${EPREFIX}/usr" \
+ --bindir="${GAMES_BINDIR}"
+}
diff --git a/games-puzzle/gnome-sudoku/gnome-sudoku-3.16.0.ebuild b/games-puzzle/gnome-sudoku/gnome-sudoku-3.16.0.ebuild
new file mode 100644
index 000000000000..9e2f5c1c059b
--- /dev/null
+++ b/games-puzzle/gnome-sudoku/gnome-sudoku-3.16.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome-games vala
+
+DESCRIPTION="Test your logic skills in this number grid puzzle"
+HOMEPAGE="https://wiki.gnome.org/Apps/Sudoku"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# fixed vala & gtk+ from gnome-3.16 branch
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ dev-libs/libgee:0.8[introspection]
+ dev-libs/json-glib
+ >=dev-libs/qqwing-1.2
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.15:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_prepare() {
+ vala_src_prepare
+ gnome-games_src_prepare
+}
+
+src_configure() {
+ # Workaround until we know how to fix bug #475318
+ gnome-games_src_configure \
+ --prefix="${EPREFIX}/usr" \
+ --bindir="${GAMES_BINDIR}"
+}
diff --git a/games-puzzle/gnome-sudoku/metadata.xml b/games-puzzle/gnome-sudoku/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/games-puzzle/gnome-sudoku/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>