summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/nightsky
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/nightsky')
-rw-r--r--games-puzzle/nightsky/Manifest1
-rw-r--r--games-puzzle/nightsky/files/nightsky-wrapper23
-rw-r--r--games-puzzle/nightsky/metadata.xml11
-rw-r--r--games-puzzle/nightsky/nightsky-20111222.ebuild95
4 files changed, 130 insertions, 0 deletions
diff --git a/games-puzzle/nightsky/Manifest b/games-puzzle/nightsky/Manifest
new file mode 100644
index 000000000000..b91b0bb4c5fc
--- /dev/null
+++ b/games-puzzle/nightsky/Manifest
@@ -0,0 +1 @@
+DIST nightskyhd-linux-1324519044.tar.gz 123971537 SHA256 def2b3b42239f9e786472a88d85ae739790f6675b8eadffe9941350d2100e9d0 SHA512 a1d4ec588fa67c3dfbefe563d37df7bd93ce6a7580e7fcedda6567f6f05f362fc478fbd6ac921854fa5fe26270a037c49f9bce2df5527a6490ff0984b9bb671e WHIRLPOOL b7aeef90eadaa47498da4d3cefd10c3f0c5ec8262ea9cf0125280aed6848ae5c8f05e591ccdedfa9a11f161f4abbb5ee03844ddee1a1c252cb61d53c5103cd0c
diff --git a/games-puzzle/nightsky/files/nightsky-wrapper b/games-puzzle/nightsky/files/nightsky-wrapper
new file mode 100644
index 000000000000..be838c7432cc
--- /dev/null
+++ b/games-puzzle/nightsky/files/nightsky-wrapper
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+HOMEDIR="${HOME}/.nightsky"
+GAMEDIR="@GAMES_PREFIX_OPT@/nightsky"
+
+# create root config dir
+[ -e "${HOMEDIR}" ] || mkdir "${HOMEDIR}"
+
+# symlink game data
+for i in `cd "${GAMEDIR}" || exit 1 ; ls -d *` ; do
+ [ -e "${HOMEDIR}/${i}" ] || ln -sf "${GAMEDIR}/${i}" "${HOMEDIR}/${i}"
+done
+# create empty Settings dir
+[ -e "${HOMEDIR}/Settings" ] || mkdir "${HOMEDIR}/Settings"
+
+cd "${HOMEDIR}"
+
+# start architecture dependent binary
+if [ -e "${HOMEDIR}/NightSkyHD_64" ] ; then
+ exec ./NightSkyHD_64 "$@"
+else
+ exec ./NightSky "$@"
+fi
diff --git a/games-puzzle/nightsky/metadata.xml b/games-puzzle/nightsky/metadata.xml
new file mode 100644
index 000000000000..d13413d31d91
--- /dev/null
+++ b/games-puzzle/nightsky/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
+
diff --git a/games-puzzle/nightsky/nightsky-20111222.ebuild b/games-puzzle/nightsky/nightsky-20111222.ebuild
new file mode 100644
index 000000000000..70d9a0a22b1d
--- /dev/null
+++ b/games-puzzle/nightsky/nightsky-20111222.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Puzzle game that puts you inside and ambient and mysterious universe"
+HOMEPAGE="http://www.nicalis.com/nightsky/"
+SRC_URI="nightskyhd-linux-1324519044.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/NightSky*
+ ${MYGAMEDIR#/}/lib/*
+ ${MYGAMEDIR#/}/lib64/*"
+
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ !bundled-libs? (
+ media-libs/freealut
+ media-libs/freeglut
+ media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ )"
+
+S=${WORKDIR}/NightSky
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ einfo "removing ${ARCH} unrelated files..."
+ rm -v NightSkyHD$(usex amd64 "" "_64") || die
+ rm -rv lib$(usex amd64 "" "64") || die
+
+ if ! use bundled-libs ; then
+ einfo "removing bundled libs..."
+ rm -rv lib* || die
+ fi
+
+ # empty dir, we create symlink here later
+ rm -r Settings || die
+
+ sed \
+ -e "s#@GAMES_PREFIX_OPT@#${GAMES_PREFIX_OPT}#" \
+ "${FILESDIR}"/${PN}-wrapper > "${T}"/${PN} || die
+}
+
+src_install() {
+ dogamesbin "${T}"/${PN}
+
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ newicon -s 128 "World/The Void/Physical"/Circle72.png ${PN}.png
+ make_desktop_entry ${PN}
+
+ fperms +x "${MYGAMEDIR}"/NightSkyHD$(usex amd64 "_64" "")
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+
+ echo
+ elog "Saves and Settings are in ~/.nightsky/Settings"
+ echo
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}