summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/splice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/splice')
-rw-r--r--games-puzzle/splice/Manifest1
-rw-r--r--games-puzzle/splice/metadata.xml6
-rw-r--r--games-puzzle/splice/splice-20121120.ebuild61
3 files changed, 68 insertions, 0 deletions
diff --git a/games-puzzle/splice/Manifest b/games-puzzle/splice/Manifest
new file mode 100644
index 000000000000..dde80364af67
--- /dev/null
+++ b/games-puzzle/splice/Manifest
@@ -0,0 +1 @@
+DIST splice-linux-1353389454.tar.gz 305838859 SHA256 5016610688f06fcc478b8669a0537614478e68077e044f21530066649830d331 SHA512 67a83a30bdb8ff0eecf9097bb4615053fcdb073daada4a24b61ae239ed56b7d2192247e80989c67554dcfcc1069c2105a6083f9fafffa4bbd66bbf29edad6a44 WHIRLPOOL 9139a3077c78331989128bfe6771c8bfe8c7f8af57712139df8ffd60d295a7bed8dd9dca0a09a35f96cb70407505f7d7b8137caa619f99d226735e37477fc1d6
diff --git a/games-puzzle/splice/metadata.xml b/games-puzzle/splice/metadata.xml
new file mode 100644
index 000000000000..01a746edb196
--- /dev/null
+++ b/games-puzzle/splice/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+</pkgmetadata>
+
diff --git a/games-puzzle/splice/splice-20121120.ebuild b/games-puzzle/splice/splice-20121120.ebuild
new file mode 100644
index 000000000000..acf8f3df79ad
--- /dev/null
+++ b/games-puzzle/splice/splice-20121120.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundle mono? (seems hardcoded)
+# icon
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="An experimental and artistic puzzler set in a microbial world"
+HOMEPAGE="http://www.cipherprime.com/games/splice/"
+SRC_URI="splice-linux-1353389454.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/Splice*
+ ${MYGAMEDIR#/}/Splice_Data/Mono/*"
+
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXext"
+
+S=${WORKDIR}/Linux
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_prepare() {
+ einfo "removing ${ARCH} unrelated files..."
+ rm -v Splice.x86$(usex amd64 "" "_64") || die
+ rm -rv Splice_Data/Mono/x86$(usex amd64 "" "_64") || die
+
+ rm README~ || die
+ mv README "${T}"/ || die
+}
+
+src_install() {
+ dodoc "${T}"/README
+
+ insinto "${MYGAMEDIR}"
+ doins -r *
+
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./Splice.x86$(usex amd64 "_64" "")" "${MYGAMEDIR}"
+
+ fperms +x "${MYGAMEDIR}"/Splice.x86$(usex amd64 "_64" "")
+ prepgamesdirs
+}