summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-23 19:20:42 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-23 19:20:55 +0200
commit2d7c75bb39c63bcead7154614999fbdd2da3a538 (patch)
tree8af5da1a98d6e2b294bd4f60cda676e73d4506ee /games-puzzle
parentmedia-gfx/gimp: Graphics device access (bug #569738) (diff)
downloadgentoo-2d7c75bb39c63bcead7154614999fbdd2da3a538.tar.gz
gentoo-2d7c75bb39c63bcead7154614999fbdd2da3a538.tar.bz2
gentoo-2d7c75bb39c63bcead7154614999fbdd2da3a538.zip
games-puzzle/pingus: Added a patch to work around Gentoo's crippled dash.
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch13
-rw-r--r--games-puzzle/pingus/pingus-0.7.6.ebuild12
2 files changed, 21 insertions, 4 deletions
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
new file mode 100644
index 000000000000..ab772d8c72e9
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-echo-e.patch
@@ -0,0 +1,13 @@
+# Work around Gentoo's crippled dash
+
+--- pingus-0.7.6/Makefile
++++ pingus-0.7.6/Makefile
+@@ -39,7 +39,7 @@
+ install -d "$(DESTDIR)$(BINDIR)"
+
+ install -D build/pingus "$(DESTDIR)$(BINDIR)/pingus.bin"
+- echo -e "#!/bin/sh\nexec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
++ printf '%s\n%s' "#!/bin/sh" "exec \"$(BINDIR)/pingus.bin\" --datadir \"$(DATADIR)\"" > "$(DESTDIR)$(BINDIR)/pingus"
+ chmod 755 "$(DESTDIR)$(BINDIR)/pingus"
+
+ install-data:
diff --git a/games-puzzle/pingus/pingus-0.7.6.ebuild b/games-puzzle/pingus/pingus-0.7.6.ebuild
index 91834802905b..49ddbd7f2b71 100644
--- a/games-puzzle/pingus/pingus-0.7.6.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -24,11 +24,15 @@ RDEPEND="media-libs/libsdl[joystick,opengl?,video]
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-noopengl.patch
+ "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-echo-e.patch
+)
+
src_prepare() {
strip-flags
- epatch \
- "${FILESDIR}"/${P}-noopengl.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ epatch "${PATCHES[@]}"
}
src_compile() {