summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 16:25:12 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:23 +0200
commitb2d5f412cb1731d58c2f0f33c95106ddd2b892d3 (patch)
tree391466f4bd30d084ab452076e323d6f03877f4bf /games-puzzle
parentgames-puzzle/tetrinet: Drop old (diff)
downloadgentoo-b2d5f412cb1731d58c2f0f33c95106ddd2b892d3.tar.gz
gentoo-b2d5f412cb1731d58c2f0f33c95106ddd2b892d3.tar.bz2
gentoo-b2d5f412cb1731d58c2f0f33c95106ddd2b892d3.zip
games-puzzle/textmaze: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/textmaze/textmaze-1.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-puzzle/textmaze/textmaze-1.2-r1.ebuild b/games-puzzle/textmaze/textmaze-1.2-r1.ebuild
new file mode 100644
index 000000000000..959e94bd77ec
--- /dev/null
+++ b/games-puzzle/textmaze/textmaze-1.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${PN}_v${PV}
+DESCRIPTION="An ncurses-based maze solving game written in Perl"
+HOMEPAGE="http://robobunny.com/projects/textmaze/html/"
+SRC_URI="http://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Curses"
+DEPEND=""
+
+S="${WORKDIR}/TextMaze"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s#/usr/local/bin/perl#/usr/bin/perl#" \
+ textmaze || die
+}
+
+src_install() {
+ dobin textmaze
+ einstalldocs
+}