summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-roguelike/wrogue
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-roguelike/wrogue')
-rw-r--r--games-roguelike/wrogue/Manifest1
-rw-r--r--games-roguelike/wrogue/files/wrogue-0.8.0b-ldflags.patch29
-rw-r--r--games-roguelike/wrogue/metadata.xml12
-rw-r--r--games-roguelike/wrogue/wrogue-0.8.0b.ebuild46
4 files changed, 88 insertions, 0 deletions
diff --git a/games-roguelike/wrogue/Manifest b/games-roguelike/wrogue/Manifest
new file mode 100644
index 000000000000..0c0e2c684c11
--- /dev/null
+++ b/games-roguelike/wrogue/Manifest
@@ -0,0 +1 @@
+DIST wrogue-0.8.0b.zip 433553 SHA256 adc79ec9a97b6b60a8b16b6fd548cf349606702e3df74f819537b01d6640483a SHA512 f8da3ccc26e36723bbf7654023cdd73747c2ffcb45420b77cc66495b596cc82ca9d90a2d239b12ea95c1185b11bad332cf41fe1b278ee34af6ff1479eb6e4d81 WHIRLPOOL 17f45cd10b4138e84e487cbe88144a8e82887c318909724912863abd53c958416d728fe65dfd59998c9b024c5fb87808f1b5cb6e469848f1c246392dc47b5e44
diff --git a/games-roguelike/wrogue/files/wrogue-0.8.0b-ldflags.patch b/games-roguelike/wrogue/files/wrogue-0.8.0b-ldflags.patch
new file mode 100644
index 000000000000..3341965e5184
--- /dev/null
+++ b/games-roguelike/wrogue/files/wrogue-0.8.0b-ldflags.patch
@@ -0,0 +1,29 @@
+--- src/linux.mak.old 2010-10-14 11:07:22.000000000 +0200
++++ src/linux.mak 2010-10-14 11:08:00.000000000 +0200
+@@ -19,7 +19,7 @@
+ # common compiler/linker flags
+ #
+ CFLAGS=-I./include -I./lib -std=c89 `sdl-config --cflags`
+-LDFLAGS=-lm `sdl-config --libs`
++LDLIBS=-lm `sdl-config --libs`
+
+
+ SRC=\
+@@ -40,7 +40,7 @@
+ #
+ .PHONY: release
+ release: CFLAGS += -pipe -O2 -fomit-frame-pointer -march=i686
+-release: LDFLAGS += -Wl,-O1
++release: LDLIBS += -Wl,-O1
+ release: STRIP_BINARY = yes
+ release: build
+
+@@ -94,7 +94,7 @@
+ @$(CC) $(CFLAGS) -o $@ -c $<
+
+ $(EXE): $(OBJ)
+- @$(CC) $(OBJ) $(LDFLAGS) -o $@
++ $(CC) $(LDFLAGS) $(OBJ) $(LDLIBS) -o $@
+
+
+
diff --git a/games-roguelike/wrogue/metadata.xml b/games-roguelike/wrogue/metadata.xml
new file mode 100644
index 000000000000..196d419134e9
--- /dev/null
+++ b/games-roguelike/wrogue/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+Warp Rogue is a gothic science fantasy roguelike game. It features RPG-like game
+mechanics, recruitable NPCs, and a consistent theme.
+</longdescription>
+ <upstream>
+ <remote-id type="freecode">wrogue</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-roguelike/wrogue/wrogue-0.8.0b.ebuild b/games-roguelike/wrogue/wrogue-0.8.0b.ebuild
new file mode 100644
index 000000000000..54a4fc05467a
--- /dev/null
+++ b/games-roguelike/wrogue/wrogue-0.8.0b.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Gothic science fantasy roguelike game"
+HOMEPAGE="https://freecode.com/projects/wrogue"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[video]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_prepare() {
+ sed -i \
+ -e "/AppData\[0\]/ s:AppData.*:strcpy(AppData, \"${GAMES_DATADIR}/${PN}/\");:" \
+ src/lib/appdir.c \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_compile() {
+ local myCPPFLAGS="-std=c99 -Iinclude -Ilib -Iui -Igenerate"
+ local myCFLAGS="$(sdl-config --cflags) ${CFLAGS}"
+ emake -C src -f linux.mak STRIP_BINARY=NO \
+ CFLAGS="${myCPPFLAGS} ${myCFLAGS}" release
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data
+ dodoc changes.txt
+
+ newicon data/ui/icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Warp Rogue" /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+}