summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-03-09 22:33:34 +0000
committerJames Le Cuirot <chewi@gentoo.org>2019-03-09 22:33:34 +0000
commit67999b34153308d2e18425b0a09dbd2a7f1284f2 (patch)
treee08262a7e19864cc31c59fae4af2fc3a0b17189d /games-roguelike
parentgames-roguelike/angband: rework USE flag logic (diff)
downloadgentoo-67999b34153308d2e18425b0a09dbd2a7f1284f2.tar.gz
gentoo-67999b34153308d2e18425b0a09dbd2a7f1284f2.tar.bz2
gentoo-67999b34153308d2e18425b0a09dbd2a7f1284f2.zip
games-roguelike/angband: EAPI bump to 7
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/angband/angband-4.1.3.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/games-roguelike/angband/angband-4.1.3.ebuild b/games-roguelike/angband/angband-4.1.3.ebuild
index 830cddc683f4..8a55a7470633 100644
--- a/games-roguelike/angband/angband-4.1.3.ebuild
+++ b/games-roguelike/angband/angband-4.1.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eapi7-ver gnome2-utils
+inherit autotools desktop xdg-utils
MAJOR_PV=$(ver_cut 1-2)
@@ -33,8 +33,8 @@ RDEPEND="X? (
media-libs/sdl-mixer[mp3]
)
)"
-DEPEND="${RDEPEND}
- dev-python/docutils
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/docutils
virtual/pkgconfig"
src_prepare() {
@@ -91,6 +91,12 @@ src_install() {
pkg_postinst() {
if use X || use sdl ; then
- gnome2_icon_cache_update
+ xdg_icon_cache_update
+ fi
+}
+
+pkg_postrm() {
+ if use X || use sdl ; then
+ xdg_icon_cache_update
fi
}