summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-11 13:05:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-11 13:13:16 +0100
commit3c62bde66d19e5822f0e5b9a2ba3adccbdfe5e83 (patch)
treec87b7583cee8c5c66f1a0a70dcc56392906a18b4 /games-rpg/manaplus
parenteclass/ruby-ng-gnome2.eclass: update homepage (diff)
downloadgentoo-3c62bde66d19e5822f0e5b9a2ba3adccbdfe5e83.tar.gz
gentoo-3c62bde66d19e5822f0e5b9a2ba3adccbdfe5e83.tar.bz2
gentoo-3c62bde66d19e5822f0e5b9a2ba3adccbdfe5e83.zip
games-rpg/manaplus: Bump to version 1.8.12.8
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.8.12.8.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index f2edaeae1238..a5860f9cbac6 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
+DIST manaplus-1.8.12.8.tar.xz 15041612 BLAKE2B dfd1ff9ca21ac9cf2647f636b8951335cd33d34badc29e6902e9fe031624bd4ce216ae2c30f24647e9ecdbb065877bcb6ef21f9a5f0b69a497c9baab25b6b694 SHA512 f57877f04404ed1021aa517e069e6a469ebb71a39fe9545264d1d9e55111c8263036c878493a8794ae77257fa3d90192505570276023282b060481ff6420587e
DIST manaplus-1.8.4.14.tar.xz 14991068 BLAKE2B d4d075230fa65ec480576521808d380781262a420783c838b5986f1a747ef672344efb684a90cbe2fea757f8256940a29250756d48cdcfc40c99466a40407bb4 SHA512 81ed9a7de09aa03f8585361a205fac97b604fbd39c78e584d2d9808fb72a789b33fc4e6bde9bedd6e0b1a53308c9299777d1434d5e81ce13e4c09ef9118f4b40
DIST manaplus-1.8.9.1.tar.xz 15024872 BLAKE2B 2b937ce4e47d04f07fc00138119b51e3d22b00ce2a44a3f0b10d409cd657cbe4e60c484b2757a50402a6181497727ccc6e5db06246342575d28af30ce7a02ab3 SHA512 18ceb8359f12b548cc4d6f0d39bcb79312c6c7fd17b188918169978b6d41d514e20b7aa2660d87f5b006af9c256cf481eedf04f9c454372bc3d6843501841f9a
diff --git a/games-rpg/manaplus/manaplus-1.8.12.8.ebuild b/games-rpg/manaplus/manaplus-1.8.12.8.ebuild
new file mode 100644
index 000000000000..df14d85dc14f
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.8.12.8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localedir=/usr/share/locale
+ --without-internalsdlgfx
+ $(use_with mumble)
+ $(use_enable nls)
+ $(use_with opengl)
+ --enable-libxml=$(usex pugixml pugixml libxml)
+ $(use_with sdl2)
+ $(use_enable test unittests)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym ../../../fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym ../../../fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym ../../../fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym ../../../fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym ../../../fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym ../../../fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym ../../../fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym ../../../fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym ../../../fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym ../../../fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym ../../../fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym ../../../fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym ../../../fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}