summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-22 16:47:35 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-22 16:48:52 +0200
commitcbc12a50fd21c37a938270a6e8abcafbe21661a8 (patch)
tree34cc1b7ce040035e8918beb089969bd26ca1700f /games-rpg/manaplus
parentx11-plugins/enigmail: Bump to version 1.9.8.2 (diff)
downloadgentoo-cbc12a50fd21c37a938270a6e8abcafbe21661a8.tar.gz
gentoo-cbc12a50fd21c37a938270a6e8abcafbe21661a8.tar.bz2
gentoo-cbc12a50fd21c37a938270a6e8abcafbe21661a8.zip
games-rpg/manaplus: Bump to version 1.7.8.19
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.8.19.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index 07ec476ca016..3131ecae2aa7 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.7.7.22.tar.xz 14894836 SHA256 b059067e7afba041b21a5cb266ed0ab9587da17b327c46952cccc691408f5515 SHA512 6dff569421123e1a3f7fb215f80da3ae20958510bc7ae6a252b85e1afe229e7e1398522ec1ddc9c3ddbde26dcd8ccbbe632b1307ff1527927cd1dc0bcad82f67 WHIRLPOOL 890a8875d3bd8294cc87409b03efad12dd104dee8b5b1eac9d200ceb4c4c7ae6d9ebf6901fea7a57e69b1415d165524001841cc09521ccb4f1976e548169a3b1
+DIST manaplus-1.7.8.19.tar.xz 14896636 SHA256 244cdaa02a480ed96ab95aa9095484068c233fc3388a9fc3ae4f6967ea4bbbf8 SHA512 d87dc8b4364b4ff8ccca7083019ec370cd3ac5ca29d02d4ce52706485219f107c932d9c75079848ea812ada5d1a6cbdb9d6437f3e6141093320d3984dd6548dd WHIRLPOOL f59d522f085bbd2e3dfe9d3f4b0d4925cfec8474a547fdb1b87fe0aad42d09eab326edccaef85c576ad7dca54bc26747bf294382a455aa776721c840e0cb4a6a
DIST manaplus-1.7.8.5.tar.xz 14896112 SHA256 0247a7cefb519cb6cf7af44bb61383f54179976dbe41fee3f9d357689c6565c1 SHA512 d5de7e467ed365123cabcbd72452c42d57bf436fbaffb339f474595c18413ef332e531cdb9b946c59c00aff28dfdbea4ed387b96bcda24c7ab9b949374e7d2ad WHIRLPOOL 574aad5ac8f1ad7fc2cc9b430fbdb13bd91ed7c86502a94ca44f668cd8b9b8ff105752470c0c16bfee801cc159e6827830abc3f523c4d05bd29d38ded120d48a
diff --git a/games-rpg/manaplus/manaplus-1.7.8.19.ebuild b/games-rpg/manaplus/manaplus-1.7.8.19.ebuild
new file mode 100644
index 000000000000..2d5897b5d6f1
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.8.19.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localedir=/usr/share/locale
+ --without-internalsdlgfx
+ $(use_with mumble)
+ $(use_enable nls)
+ $(use_with opengl)
+ --enable-libxml=$(usex pugixml pugixml libxml)
+ $(use_with sdl2)
+ $(use_enable test unittests)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}