summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-17 16:26:59 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-17 19:00:52 -0500
commit41067a7c8676770774e170f6e4a2e99467c380af (patch)
tree6b534e1b6918fe4d2c12e23ed4bb9087a9231aeb /games-rpg/vendetta-online-bin
parentgames-rpg/twclone: remove deprecated games eclass (diff)
downloadgentoo-41067a7c8676770774e170f6e4a2e99467c380af.tar.gz
gentoo-41067a7c8676770774e170f6e4a2e99467c380af.tar.bz2
gentoo-41067a7c8676770774e170f6e4a2e99467c380af.zip
games-rpg/vendetta-online-bin: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-rpg/vendetta-online-bin')
-rw-r--r--games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296-r1.ebuild b/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296-r1.ebuild
new file mode 100644
index 000000000000..9900b3f03e74
--- /dev/null
+++ b/games-rpg/vendetta-online-bin/vendetta-online-bin-1.8.296-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit eutils unpacker
+
+DESCRIPTION="Space-based MMORPG"
+HOMEPAGE="http://www.vendetta-online.com/"
+SRC_URI="amd64? (
+ http://mirror.cle.vendetta-online.com/vendetta-linux-amd64-installer.sh
+ -> ${P}-amd64.sh
+ )
+ x86? (
+ http://mirror.cle.vendetta-online.com/vendetta-linux-ia32-installer.sh
+ -> ${P}-x86.sh
+ )"
+
+LICENSE="guild"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="virtual/opengl
+ x11-libs/gtk+:2"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_prepare() {
+ # Won't do much good since this is a -bin, but there's no bin_prepare :)
+ default
+
+ # scanelf: rpath_security_checks(): Security problem with relative DT_RPATH '.'
+ for file in install/drivers/{gkvc.so,soundbackends/libalsa_linux_amd64.so,soundbackends/libpulseaudio_linux_amd64.so}
+ do
+ patchelf --set-rpath '$ORIGIN' $file || die
+ done
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ insinto "${dir}"
+ doins -r * || die "doins failed"
+ fperms +x "${dir}"/{vendetta,install/{media.rlb,update.rlb,vendetta}} \
+ || die "fperms failed"
+
+ sed \
+ -e "s:DATADIR:${dir}:" \
+ "${FILESDIR}"/vendetta > "${T}"/vendetta \
+ || die "sed failed"
+
+ dobin "${T}"/vendetta
+ newicon install/manual/images/ships.valkyrie.jpg ${PN}.jpg
+ make_desktop_entry vendetta "Vendetta Online" /usr/share/pixmaps/${PN}.jpg
+}