summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-03-08 11:32:45 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-03-08 11:32:45 +0100
commit4d9a34d2b80bb6ba6ac7f5d4abcad3c58e7be025 (patch)
treeba07abb4b21ae137d771bd951c1ab0c90e4d95ea /games-rpg
parentdev-util/checkbashisms: Removed old. (diff)
downloadgentoo-4d9a34d2b80bb6ba6ac7f5d4abcad3c58e7be025.tar.gz
gentoo-4d9a34d2b80bb6ba6ac7f5d4abcad3c58e7be025.tar.bz2
gentoo-4d9a34d2b80bb6ba6ac7f5d4abcad3c58e7be025.zip
games-rpg/manaplus: Bump to version 1.7.3.4
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.3.4.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index bac1f39f790e..a1d0bc0c13a9 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.7.2.18.tar.xz 14768848 SHA256 308bd47abcc0d2d032deb2137766820288b9fff4821f38130dc8d50220234545 SHA512 424375a5e0116650bd0be205f5fe3cf6eb25782b22cef7f6a9caa8fdc4c5bab0e0323cfd8f9f8585729e2995977c1371ddab76af354dc759066d27b672a00eb1 WHIRLPOOL bcb1cffd5b9d8b86b00f5345ee94e18f812f3d54743329d30292335354e06069709b6eb7e976e74381856449b599545dc733712369a4fa4a147ef61b8cd078f4
DIST manaplus-1.7.2.4.tar.xz 14787184 SHA256 19aea5f7e286d395918ea4bce3d1823efe1178a50e3978668461c880dd9dc105 SHA512 94dd6b5e04b0edaa9cce54c0a23ae23a7d5299b4594efb064eecdc3ed305ec8d622085deac5641f359293b300f8854bd61b693b312d7c8dbc7d124a15108412d WHIRLPOOL 148cb52d6da40b8184f3b6ffc598eba06bce8f670cf9d7e70b94a730fcb23dc5e898ba26177ce1304997fddb08953f3fb4730b5c06daacb3c3ce7171aa61bb39
+DIST manaplus-1.7.3.4.tar.xz 14794704 SHA256 20d8ccd4d91edc0f9de4db9d5c0ae99906be393f6d762b87c2d784279ffe7d55 SHA512 86c45d5e2964772bd87bcb06b55dc8481ec1b36c3f5523015f2eba4c0adc15ea7d8ea9db7b98779f76cdbdd869687b93cc2f1a0012db44f7fffcd3ee3ffdae06 WHIRLPOOL 9caf975ec64183ea3241c0be29ddcde57902c0cbc945b8fc267ff8bbf77586043eaadc8277f771bffba2901c4da1663b094cc3169dd9bf1a9009dd6f9b1da0b3
diff --git a/games-rpg/manaplus/manaplus-1.7.3.4.ebuild b/games-rpg/manaplus/manaplus-1.7.3.4.ebuild
new file mode 100644
index 000000000000..7896a6774aff
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.3.4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --localedir=/usr/share/locale \
+ --without-internalsdlgfx \
+ $(use_with mumble) \
+ $(use_enable nls) \
+ $(use_with opengl) \
+ --enable-libxml=$(usex pugixml pugixml libxml) \
+ $(use_with sdl2) \
+ $(use_enable test unittests)
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}