summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-06-22 21:15:27 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-06-22 21:15:27 +0100
commit7a68c619421462fc11455e4cad37e75a32a0b215 (patch)
treefd282ea6e28d6ad380a99f5f6d555dac474ea3c7 /games-rpg
parentsys-kernel/gentoo-sources: Linux patch 4.19.54 and 4.19.55 (diff)
downloadgentoo-7a68c619421462fc11455e4cad37e75a32a0b215.tar.gz
gentoo-7a68c619421462fc11455e4cad37e75a32a0b215.tar.bz2
gentoo-7a68c619421462fc11455e4cad37e75a32a0b215.zip
games-rpg/hatoful-boyfriend: New package
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/hatoful-boyfriend/Manifest1
-rw-r--r--games-rpg/hatoful-boyfriend/hatoful-boyfriend-0.ebuild51
-rw-r--r--games-rpg/hatoful-boyfriend/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/games-rpg/hatoful-boyfriend/Manifest b/games-rpg/hatoful-boyfriend/Manifest
new file mode 100644
index 000000000000..b450d386c88f
--- /dev/null
+++ b/games-rpg/hatoful-boyfriend/Manifest
@@ -0,0 +1 @@
+DIST Hatoful_Boyfriend_Linux.zip 474221347 BLAKE2B 95f1d819ec75eeced844cbe5c0b0568bbe35052eddab223d34e683e1dab381c6abcb654e22e65aafcf8629beaebae7034ea82443c543964c197c3e16ef824d21 SHA512 0ef35be35d0c4d9815427fae078a266b3ceafba68cd87d733db23171d92396535974e0d83f1e7f441c666d064a75ddcc82a9807c347922aed84790ed1f6fda21
diff --git a/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0.ebuild b/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0.ebuild
new file mode 100644
index 000000000000..a863466144da
--- /dev/null
+++ b/games-rpg/hatoful-boyfriend/hatoful-boyfriend-0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+MY_PN="Hatoful Boyfriend"
+DESCRIPTION="Japanese visual novel and dating simulator where birds rule the Earth"
+HOMEPAGE="http://clione.halfmoon.jp/hatoful-boyfriend/english.html"
+SRC_URI="${MY_PN// /_}_Linux.zip"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ virtual/glu
+ virtual/opengl
+"
+
+S="${WORKDIR}/${MY_PN}_Linux"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_install() {
+ exeinto "${DIR}"
+ newexe hatoful.$(usex amd64 x86_64 x86) hatoful
+ dosym "${DIR}"/hatoful /usr/bin/${PN}
+
+ insinto "${DIR}"
+ doins -r hatoful_Data/
+ rm -r "${ED}/${DIR}"/hatoful_Data/*/$(usex amd64 x86 x86_64) || die
+
+ newicon -s 128 hatoful_Data/Resources/UnityPlayer.png ${PN}.png
+ make_desktop_entry ${PN} "${MY_PN}"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-rpg/hatoful-boyfriend/metadata.xml b/games-rpg/hatoful-boyfriend/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-rpg/hatoful-boyfriend/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>