summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-06-19 01:53:30 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-06-19 01:53:30 +0200
commitc5505d85911967b036eca05ed51f8324315de211 (patch)
treed42280466beaaf560a7db2ff496c9ff8d9766302 /games-rpg
parentx11-libs/cairo: Removed opengl-apple from (R)DEPEND. (diff)
downloadgentoo-c5505d85911967b036eca05ed51f8324315de211.tar.gz
gentoo-c5505d85911967b036eca05ed51f8324315de211.tar.bz2
gentoo-c5505d85911967b036eca05ed51f8324315de211.zip
games-rpg/manaplus: Bump to version 1.7.6.10
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.6.10.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index e403a28cef24..44d53ec095d8 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.7.5.14.tar.xz 14813736 SHA256 9019e48a19c47674355ae7524f513e45785a05be166e8a302d93e536653ab8ac SHA512 4c95554c590cc8b96bcd66f528e26b184ff3f9c60230130b092731a8b310bb64ee8fdeab44c0415b7cf9b81ed5ab9aca90ff3b167e895413c0139c1909c44c37 WHIRLPOOL fb36cdbae6f15dd65104b64a58e24f083fcb50bc26d6219d1d4984d0114a1a846e72055a7b7fbcfef72a9a44477956ad81a3d876c9d225186a1460851fbd6262
DIST manaplus-1.7.5.27.tar.xz 14844236 SHA256 2eea734ccb5a869c3a0e97cc93a88c9bba9cd22d7fbf95dfeb1475fda7ee48ec SHA512 71c73323705c5deb98d27701801deac2696ac7b99aa3eb0bdebc2ee876c64b77496e4c5c02674934218bef74287bba676a4e5866fab8ad53be3712207e83d5c4 WHIRLPOOL 8dfa66d7a8c13a0947020f528f08389d8d97b4e2ffca3b6b6aba3d82dd5f811db960b2608bb3b1bf16d2e0dbdfb5573010b891d1538df6b048a4b18a737ae0a7
+DIST manaplus-1.7.6.10.tar.xz 14847988 SHA256 14e20a63d33fc1a30af16e7143e3015baead9db957ea2c38a90a08fcefe6fa50 SHA512 ca8a191c37758883d593dd1f8718fe4c8f9620fac5fd6034aad12a84815ec75e725e26a868673fe25c59efef7f21012869f6f90156ca93d2d48b26c8ffdd87cf WHIRLPOOL fbee48f38ba09ec5e9125e17311d844d0a2af464a90d962f7eb3d3ed06a7e93f035f12391ff397307b7e9408002159948f37718f0bcb642e2df78521b5164ce3
diff --git a/games-rpg/manaplus/manaplus-1.7.6.10.ebuild b/games-rpg/manaplus/manaplus-1.7.6.10.ebuild
new file mode 100644
index 000000000000..7896a6774aff
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.6.10.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --localedir=/usr/share/locale \
+ --without-internalsdlgfx \
+ $(use_with mumble) \
+ $(use_enable nls) \
+ $(use_with opengl) \
+ --enable-libxml=$(usex pugixml pugixml libxml) \
+ $(use_with sdl2) \
+ $(use_enable test unittests)
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}