summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2015-10-24 17:43:01 +0200
committerTupone Alfredo <tupone@gentoo.org>2015-10-24 17:43:01 +0200
commitfcc4281c0eacb8d3e125ed2c597c7d22ed2da640 (patch)
tree66da6fc769050d70210deb12cacd753db185801c /games-rpg
parentprofiles: Mask USE=lz4 in net-mail/dovecot for s390, sh and sparc (diff)
downloadgentoo-fcc4281c0eacb8d3e125ed2c597c7d22ed2da640.tar.gz
gentoo-fcc4281c0eacb8d3e125ed2c597c7d22ed2da640.tar.bz2
gentoo-fcc4281c0eacb8d3e125ed2c597c7d22ed2da640.zip
games-rpg/freedroid: compile with format-security. Bug #544366
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/freedroid/files/freedroid-1.0.2-format.patch29
-rw-r--r--games-rpg/freedroid/freedroid-1.0.2.ebuild4
2 files changed, 33 insertions, 0 deletions
diff --git a/games-rpg/freedroid/files/freedroid-1.0.2-format.patch b/games-rpg/freedroid/files/freedroid-1.0.2-format.patch
new file mode 100644
index 000000000000..ebb7089853bd
--- /dev/null
+++ b/games-rpg/freedroid/files/freedroid-1.0.2-format.patch
@@ -0,0 +1,29 @@
+--- src/init.c.old 2015-10-24 17:37:24.431514375 +0200
++++ src/init.c 2015-10-24 17:37:43.057157826 +0200
+@@ -554,13 +554,13 @@
+ * following gnu-coding standards for command line interfaces */
+ case 'v':
+ printf ("\n%s %s \n", PACKAGE, VERSION);
+- printf (copyright);
++ printf ("%s", copyright);
+ exit (0);
+ break;
+
+ case 'h':
+ case '?':
+- printf (usage_string);
++ printf ("%s", usage_string);
+ exit (0);
+ break;
+
+--- src/misc.c.old 2015-10-24 17:37:54.368941282 +0200
++++ src/misc.c 2015-10-24 17:38:10.202638172 +0200
+@@ -889,7 +889,7 @@
+ if (db_level <= debug_level)
+ {
+ vsnprintf (buffer, 5000, fmt, args);
+- fprintf (stderr, buffer);
++ fprintf (stderr, "%s", buffer);
+ fflush (stderr);
+ }
+
diff --git a/games-rpg/freedroid/freedroid-1.0.2.ebuild b/games-rpg/freedroid/freedroid-1.0.2.ebuild
index dde856f82f4a..86e8499908c2 100644
--- a/games-rpg/freedroid/freedroid-1.0.2.ebuild
+++ b/games-rpg/freedroid/freedroid-1.0.2.ebuild
@@ -22,6 +22,10 @@ DEPEND="media-libs/libsdl[joystick,sound,video]
media-libs/sdl-mixer[mod,vorbis]
media-libs/libvorbis"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format.patch
+}
+
src_install() {
default
find "${D}" -name "Makefile*" -exec rm -f '{}' +