summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-server/cyphesis/cyphesis-0.6.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-server/cyphesis/cyphesis-0.6.2.ebuild')
-rw-r--r--games-server/cyphesis/cyphesis-0.6.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-server/cyphesis/cyphesis-0.6.2.ebuild b/games-server/cyphesis/cyphesis-0.6.2.ebuild
new file mode 100644
index 000000000000..1158cc44c460
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit toolchain-funcs autotools python-single-r1 eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/index.php/components/cyphesis/"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=">=media-libs/skstream-0.3.9
+ >=dev-games/wfmath-1.0.1
+ >=dev-games/mercator-0.3.3
+ dev-libs/libgcrypt:0
+ dev-libs/libsigc++:2
+ sys-libs/ncurses
+ sys-libs/readline
+ >=media-libs/atlas-c++-0.6.3
+ >=media-libs/varconf-0.6.4
+ dev-db/postgresql"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.40
+ dev-libs/libxml2
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}