summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-21 12:56:23 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-21 15:56:53 -0500
commit0f4174060aaa6c36cd002730ed123beb32986299 (patch)
treea4e6d69f77725d8a8740379068a5d661780ead6b /games-simulation/crrcsim
parentgames-simulation/crashtest: remove deprecated games eclass (diff)
downloadgentoo-0f4174060aaa6c36cd002730ed123beb32986299.tar.gz
gentoo-0f4174060aaa6c36cd002730ed123beb32986299.tar.bz2
gentoo-0f4174060aaa6c36cd002730ed123beb32986299.zip
games-simulation/crrcsim: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-simulation/crrcsim')
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.12-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/crrcsim-0.9.12-r2.ebuild b/games-simulation/crrcsim/crrcsim-0.9.12-r2.ebuild
new file mode 100644
index 000000000000..6bd74400ce45
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.12-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+WANT_AUTOMAKE="1.10"
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="https://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="
+ media-libs/libsdl[X,sound,joystick,opengl,video]
+ media-libs/plib
+ sci-mathematics/cgal
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-buildsystem.patch
+)
+
+src_prepare() {
+ default
+
+ if has_version "sci-mathematics/cgal[gmp(+)]" ; then
+ eapply "${FILESDIR}"/${PN}-cgal_gmp.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir="/usr/share" \
+ --datarootdir="${EPREFIX%/}/usr/share" \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with portaudio)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS HISTORY NEWS README
+ doicon -s 32 packages/icons/${PN}.png
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}