summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/flightgear/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/flightgear/files')
-rw-r--r--games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch30
-rw-r--r--games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch54
-rw-r--r--games-simulation/flightgear/files/ac3d.vim1
-rw-r--r--games-simulation/flightgear/files/nasal.vim1
4 files changed, 86 insertions, 0 deletions
diff --git a/games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch b/games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch
new file mode 100644
index 000000000000..e14920b246c2
--- /dev/null
+++ b/games-simulation/flightgear/files/0001-flightgear-3.4.0-cmake.patch
@@ -0,0 +1,30 @@
+From 06a260822c0eb10f47533a2cbf5cbbc968878c17 Mon Sep 17 00:00:00 2001
+From: James Turner <zakalawe@mac.com>
+Date: Tue, 17 Mar 2015 23:33:57 +0000
+Subject: [PATCH] Make 3.2.1 fix: make thread check platform specific.
+
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8847614..c881c32 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -109,6 +109,8 @@ IF(APPLE)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mmacosx-version-min=10.7")
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR
+ ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
++ find_package(Threads REQUIRED)
++
+ set(USE_DBUS_DEFAULT 1)
+
+ find_package(UDev)
+@@ -230,7 +232,6 @@ endif(EVENT_INPUT)
+ # check required dependencies
+ find_package(Boost REQUIRED)
+ find_package(ZLIB REQUIRED)
+-find_package(Threads REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(OpenAL REQUIRED)
+ find_package(OpenSceneGraph 3.2.0 REQUIRED
diff --git a/games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch b/games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch
new file mode 100644
index 000000000000..2151acdbbcf4
--- /dev/null
+++ b/games-simulation/flightgear/files/0002-flightgear-3.4.0-cmake.patch
@@ -0,0 +1,54 @@
+From 14405fe2e397b9a6ab9b004cb8c7459eeb41ec59 Mon Sep 17 00:00:00 2001
+From: "Rebecca N. Palmer" <rebecca_palmer@zoho.com>
+Date: Fri, 3 Apr 2015 19:15:52 +0100
+Subject: [PATCH] Fix compile with CMake 3.2.1, by Kevin Seroux
+
+Explicitly link X11, as this no longer comes with OpenGL
+---
+ CMakeLists.txt | 1 +
+ src/Main/CMakeLists.txt | 4 +++-
+ utils/fgviewer/CMakeLists.txt | 4 ++++
+ 3 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c881c32..c443f58 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -110,6 +110,7 @@ IF(APPLE)
+ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR
+ ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ find_package(Threads REQUIRED)
++ find_package(X11 REQUIRED)
+
+ set(USE_DBUS_DEFAULT 1)
+
+diff --git a/src/Main/CMakeLists.txt b/src/Main/CMakeLists.txt
+index 949b379..4b6926e 100644
+--- a/src/Main/CMakeLists.txt
++++ b/src/Main/CMakeLists.txt
+@@ -130,7 +130,9 @@ endif()
+ if (CRASHRPT_FOUND)
+ target_link_libraries(fgfs ${CRASHRPT_LIBRARY})
+ endif()
+-
++if(X11_FOUND)
++ target_link_libraries(fgfs ${X11_LIBRARIES})
++endif()
+ target_link_libraries(fgfs
+ ${SQLITE3_LIBRARY}
+ ${SIMGEAR_LIBRARIES}
+diff --git a/utils/fgviewer/CMakeLists.txt b/utils/fgviewer/CMakeLists.txt
+index 165be74..bfc52ad 100644
+--- a/utils/fgviewer/CMakeLists.txt
++++ b/utils/fgviewer/CMakeLists.txt
+@@ -42,6 +42,10 @@ else()
+ endif()
+
+ add_executable(fgviewer ${FGVIEWER_SOURCES} ${FGVIEWER_RTI_SOURCES})
++if(X11_FOUND)
++ target_link_libraries(fgviewer ${X11_LIBRARIES})
++endif()
++
+ target_link_libraries(fgviewer
+ ${SIMGEAR_LIBRARIES}
+ ${OPENSCENEGRAPH_LIBRARIES}
diff --git a/games-simulation/flightgear/files/ac3d.vim b/games-simulation/flightgear/files/ac3d.vim
new file mode 100644
index 000000000000..6477d949b762
--- /dev/null
+++ b/games-simulation/flightgear/files/ac3d.vim
@@ -0,0 +1 @@
+au BufRead,BufNewFile *.ac set filetype=ac3d
diff --git a/games-simulation/flightgear/files/nasal.vim b/games-simulation/flightgear/files/nasal.vim
new file mode 100644
index 000000000000..65a2ed17fc26
--- /dev/null
+++ b/games-simulation/flightgear/files/nasal.vim
@@ -0,0 +1 @@
+au BufRead,BufNewFile *.nas set filetype=nasal