summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-16 18:16:19 -0500
committerAustin English <wizardedit@gentoo.org>2016-09-16 18:23:24 -0500
commit7514f5949bec7efe9b50f606af2678a829b6e741 (patch)
tree7f78fcdad7bde85aab8ceffeec1e6bea9851cfbf /games-simulation/gl117
parentdev-python/selectors34: Add new package (diff)
downloadgentoo-7514f5949bec7efe9b50f606af2678a829b6e741.tar.gz
gentoo-7514f5949bec7efe9b50f606af2678a829b6e741.tar.bz2
gentoo-7514f5949bec7efe9b50f606af2678a829b6e741.zip
games-simulation/gl117: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-simulation/gl117')
-rw-r--r--games-simulation/gl117/files/gl117-1.3.2-mode.patch4
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild38
2 files changed, 40 insertions, 2 deletions
diff --git a/games-simulation/gl117/files/gl117-1.3.2-mode.patch b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
index c74e07c1cafd..d3f13084a96f 100644
--- a/games-simulation/gl117/files/gl117-1.3.2-mode.patch
+++ b/games-simulation/gl117/files/gl117-1.3.2-mode.patch
@@ -1,5 +1,5 @@
---- src/main.cpp.orig 2010-07-13 09:35:18.374122609 +0100
-+++ src/main.cpp 2010-07-13 09:35:45.334955120 +0100
+--- a/src/main.cpp 2010-07-13 09:35:18.374122609 +0100
++++ b/src/main.cpp 2010-07-13 09:35:45.334955120 +0100
@@ -71,8 +71,7 @@ int mode = 0;
// pre-defined screen resolutions (x, y, bpp, fullscreen)
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f20c371d11a9
--- /dev/null
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P="gl-117-${PV}-src"
+DESCRIPTION="An action flight simulator"
+HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
+SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freeglut
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-mixer[mod]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mode.patch
+)
+
+src_install() {
+ DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
+ default
+ newicon doc/src/falcon.jpg ${PN}.jpg
+ make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ doman doc/gl-117.6
+}