summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-11 00:06:44 +0000
committerSam James <sam@gentoo.org>2024-11-11 00:07:05 +0000
commit377d884ea95e4494bb9980229161a41a59ed42e2 (patch)
tree75e00db13d017b92c4d3c983210eb9e734eeeeab /games-simulation
parentsys-kernel/git-sources: add 6.12_rc7 (diff)
downloadgentoo-377d884ea95e4494bb9980229161a41a59ed42e2.tar.gz
gentoo-377d884ea95e4494bb9980229161a41a59ed42e2.tar.bz2
gentoo-377d884ea95e4494bb9980229161a41a59ed42e2.zip
games-simulation/openttd: fix build w/ icu-76
This is needed even with 5de097998a3ed84e9af43fce547aa143b5e61c14. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/files/openttd-13.4-icu-76.1.patch27
-rw-r--r--games-simulation/openttd/openttd-13.4.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/games-simulation/openttd/files/openttd-13.4-icu-76.1.patch b/games-simulation/openttd/files/openttd-13.4-icu-76.1.patch
new file mode 100644
index 000000000000..840942c01a67
--- /dev/null
+++ b/games-simulation/openttd/files/openttd-13.4-icu-76.1.patch
@@ -0,0 +1,27 @@
+https://github.com/OpenTTD/OpenTTD/commit/14fac2ad37bfb9cec56b4f9169d864f6f1c7b96e (rebased)
+
+From 14fac2ad37bfb9cec56b4f9169d864f6f1c7b96e Mon Sep 17 00:00:00 2001
+From: fundawang <fundawang@yeah.net>
+Date: Tue, 5 Nov 2024 19:12:34 +0800
+Subject: [PATCH] Fix: build with icu >= 76 where icu-i18n and icu-uc become
+ separated (#13048)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -135,7 +135,7 @@ if(NOT OPTION_DEDICATED)
+ endif()
+ find_package(Fluidsynth)
+ find_package(Fontconfig)
+- find_package(ICU OPTIONAL_COMPONENTS i18n lx)
++ find_package(ICU OPTIONAL_COMPONENTS i18n lx uc)
+ endif()
+ endif()
+ endif()
+@@ -267,6 +267,7 @@ if(NOT OPTION_DEDICATED)
+ link_package(Fontconfig TARGET Fontconfig::Fontconfig)
+ link_package(ICU_lx)
+ link_package(ICU_i18n)
++ link_package(ICU_uc)
+
+ if(SDL2_FOUND AND OPENGL_FOUND AND UNIX)
+ # SDL2 dynamically loads OpenGL if needed, so do not link to OpenGL when
diff --git a/games-simulation/openttd/openttd-13.4.ebuild b/games-simulation/openttd/openttd-13.4.ebuild
index 11d583b49c7f..c647f80d4818 100644
--- a/games-simulation/openttd/openttd-13.4.ebuild
+++ b/games-simulation/openttd/openttd-13.4.ebuild
@@ -65,6 +65,7 @@ DOCS=( docs/directory_structure.md )
PATCHES=(
"${FILESDIR}/${PN}-1.11.2_dont_compress_man.patch"
"${FILESDIR}/${PN}-13.4-gcc15.patch"
+ "${FILESDIR}/${PN}-13.4-icu-76.1.patch"
)
src_prepare() {